the network revolves around you™

HOME      PRODUCTS      DOWNLOAD      STORE      DASHBOARD        DOCUMENTS      COMMUNITY MESH

Community


All times are UTC - 5 hours




Post new topic Reply to topic  [ 9 posts ] 
Author Message
 Post subject: Username and password do not match
PostPosted: Fri Oct 09, 2009 9:44 am 
Offline

Joined: Fri Oct 02, 2009 7:06 am
Posts: 17
I get the message 'Username and password do not match' when I try to log into NeoRouter Configuration Explorer and "Neorouter cannot sign in right now. Please contact your administrator. (hr=0x80820102)" when I try to sign in with NeoRouter Network Explorer.

The computer is connecting over the internet to the NeoRouter Server. I am using the same username and userpassword (together with the domainname for the server) as I do when I connect fine on the same LAN (and for that matter the computer on which the server is running) using username and userpassword with servername rather than domainname.

If I do a test on the Dashboard (https://www.neorouter.com/Dashboard/domainstatus.aspx) logging in with domainname and domainpassword I can see that the domainname is connecting to the server correctly (with the port forwarded in the router).

I have also found that if I try to log in to the Configuation Explorer or the Network Explorer with the domainname rather than the servername with another computer on the local network I come up with the same errors as described above.

Any ideas what I might be doing wrong?


Top
 Profile  
 
 Post subject: Re: Username and password do not match
PostPosted: Fri Oct 09, 2009 11:17 am 
Offline

Joined: Mon Dec 22, 2008 10:19 pm
Posts: 436
hi upekshapriya,

It seems you may have mistaken domain name and password for user accounts.

Domain name is a unique identifier for your virtual LAN. When logging into NR network/config explorer, you need to enter the domain name in the "log on to" box. NR provides a "dynamic DNS" service that can locate your NR server.

You can create multiple user accounts in your domain. If you are using NR server for Windows, the install wizard will guide you and set up the first user account. If you are using Linux/Mac NR server, your first user account is the same as that you use to log into the operating system. When logging into NR network/config explorer, you need to enter the username and password accordingly. You can also use NR config explorer to create user accounts for your family members or friends.

_________________
Luke - NeoRouter Team


Top
 Profile  
 
 Post subject: Re: Username and password do not match
PostPosted: Fri Oct 09, 2009 12:12 pm 
Offline

Joined: Fri Oct 02, 2009 7:06 am
Posts: 17
Thank you for your prompt reply Luke, however I don't think I have mistaken the domainname and domainpassword for username and userpassword.

In Configuration Explorer I enter an adminstrator username and userpassword and in "log on to" I put the name the Windows computer name for the server eg computer1 - the name I use for looking at windows shares on other computers \\computer1\share - and it all works fine within the LAN.

If I want to access Configuation Explorer on a computer outside the LAN I am entering the same username and userpassword but this time I enter the domainname for the server in the "log on to" box - the one that I can test in the Dashboard on this site. That's where it doesn't seem to work for me.

Putting the domainname into the "log on to" box also doesn't seem to work when I am on the same network.

Have I understood this correctly and if so what can be going wrong?


Top
 Profile  
 
 Post subject: Re: Username and password do not match
PostPosted: Fri Oct 09, 2009 12:20 pm 
Offline

Joined: Mon Dec 22, 2008 10:19 pm
Posts: 436
Looked into it a little more. the hr=0x80820102 means "Computer Not Found".

The connection between your server and the client has no problem, but the server cannot find your current computer in the database for some reasons, for example: the database is busy at the moment or the the database file has been damaged.

Generally it should not happen. When you log in to a server from the Network Explorer with the proper user's credentials, it will register the computer automatically at the first time.

You can try to restart your server and try to connect to it using the Configuration Explorer again. If it still does not work, you can backup the current DB files, delete them and try to re-install the server.

_________________
Luke - NeoRouter Team


Top
 Profile  
 
 Post subject: Re: Username and password do not match
PostPosted: Fri Oct 09, 2009 12:29 pm 
Offline

Joined: Fri Oct 02, 2009 7:06 am
Posts: 17
I am a little confused because Dragonfly in viewtopic.php?f=3&t=8&view=previous says that "error hr=0x80820102 indicates that you have entered wrong username or password".

However there only seems to be a problem if I use the domainname in the "log on to" box rather than the computername of the server.

I have rebooted the server and still have a problem. How do I back up the current DB files before deleting them and reinstalling the server?


Top
 Profile  
 
 Post subject: Re: Username and password do not match
PostPosted: Fri Oct 09, 2009 1:14 pm 
Offline

Joined: Sun Nov 16, 2008 6:41 am
Posts: 1638
Hi upekshapriya,

In the latest version, the error code has the accurate meaning as Luck said. The error code 0x80820102 means "Computer Not Found".

There is no problem with your domain or router settings, while the database seems have problem.

Try this:

1. Backup the main configuration folder, see the FAQ

2. If the server is running on Windows, simply remove the main configuration folder and re-install again.

3. If the server is running on Linux, Mac or in-a-box version, just need to delete the database NeoRouter_0_0_1.db. (Note: do not delete the certificates: server.crt and server.key) Then restart the server.

4. When the server started, try to log on to it.

Let us know if you still have problem.

Thanks,
KevinZ - NeoRouter team


Top
 Profile  
 
 Post subject: Re: Username and password do not match
PostPosted: Fri Oct 09, 2009 1:42 pm 
Offline

Joined: Fri Oct 02, 2009 7:06 am
Posts: 17
Thanks for that Kevin. I've reinstalled the server (actually from scratch after all) and still I am unable to log in with the domainname in the 'log in to' box, just the computername of the server on the LAN!

Not sure where to go from here.


Top
 Profile  
 
 Post subject: Re: Username and password do not match
PostPosted: Fri Oct 09, 2009 3:09 pm 
Offline

Joined: Sun Nov 16, 2008 6:41 am
Posts: 1638
More like the "media hairpin feature" issue

Please verify it.

If so, you have to access to the server using private IP in the LAN but using the domain name outside the LAN.

Thanks,
KevinZ - NeoRouter team


Top
 Profile  
 
 Post subject: Re: Username and password do not match
PostPosted: Tue Oct 13, 2009 5:39 pm 
Offline

Joined: Fri Oct 02, 2009 7:06 am
Posts: 17
I can confirm that from Windows computers that I can only use the private IP in the LAN and the domain name outside the LAN.

However with Mac OS 10.6 Snow Leopard and Ubuntu 8.0.4 and running nrclientcmd I enter the domain name as I am requested along with a user name and password and it works within the LAN!

Strange that it doesn't work to use the domain name inside the LAN for Windows, but for Linux and Mac OS it works fine.

Any ideas why this might be the case?


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 9 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: Google [Bot] and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron