Community


All times are UTC - 5 hours




Post new topic Reply to topic  [ 27 posts ]  Go to page 1, 2, 3  Next
Author Message
 Post subject: [Issue] Windows 10 1511/1607/1703 after-reboot issue
PostPosted: Fri Jan 08, 2016 2:10 pm 
Offline

Joined: Tue Feb 10, 2009 4:11 am
Posts: 96
Recently I updated my Windows 10 systems to version 1511, build 10586.36 and I started to see this issue happening intermittently, and I am wondering if anyone else gets the same problem and if any workarounds exist.

The issue: After Windows 10 reboots (due to various system updates), sometimes it cannot connect to other Neorouter clients, this does not happen every time but it does very often (roughly the chance is about 40%).

Neorouter version: Free, 2.3.1.4360[1].

Let's say, I have NR client system A (Windows 10 v1511), and several other systems: B (Windows 10 v1511, NR client), C (Linux, NR server + NR client)

After system A reboots, its NR network explorer shows itself as "online", and it sees B and C (both online), somehow,
1. when A tries to ping B, A gets no replies
2. when A tries to ping C, A gets no replies

At the same time, B and C both see that A is online, but
1. when B tries to ping A, B gets no replies
2. when C tries to ping A, C gets no replies
3. when B tries to ping C, B gets replies
4. when C tries to ping B, C gets replies

system A will stay in this state and never recover itself (I waited for several hours).

However, from system A, if I right-click on the network connection tray icon and choose "Open Network and Sharing Center", a few seconds after the Network and Sharing Center dialog comes up, system A's Neorouter connections to other systems are fully recovered and working properly from that point... until next reboot.

I saw this problem on several Windows 10 systems, with various CPUs (Intel, AMD) and network card (wired, wireless, different brands, etc.)

I did not see this before Windows 10 v1511 (Windows 7 / 8.1 / 10 v1024)

Did anyone see this problem?


EDIT:
I have seen this problem with the following English (US) Windows 10 builds (both Home and Pro)
Windows 10 Version 1511, OS Build 10586.36
Windows 10 Version 1511, OS Build 10586.63
Windows 10 Version 1511, OS Build 10586.71
Windows 10 Version 1511, OS Build 10586.104
Windows 10 Version 1511, OS Build 10586.122
Windows 10 Version 1511, OS Build 10586.164
Windows 10 Version 1511, OS Build 10586.218
Windows 10 Version 1511, OS Build 10586.420
Windows 10 Version 1511, OS Build 10586.494
=== windows 10 anniversary update, unfortunately, I still saw the same issue:
Windows 10 Version 1607, OS Build 14393.10
Windows 10 Version 1607, OS Build 14393.51
Windows 10 Version 1607, OS Build 14393.82
Windows 10 Version 1607, OS Build 14393.105
Windows 10 Version 1607, OS Build 14393.187



With the new version (2.3.2.4450), this issue has been fixed.



The problem is back:
Windows 10 Version: 1703, OS Build 15063.332





Last edited by ElTopo on Mon Jun 05, 2017 2:33 pm, edited 20 times in total.

Top
 Profile  
 
 Post subject: Re: Windows 10 1511 after-reboot issue
PostPosted: Thu Jan 14, 2016 6:07 pm 
Offline

Joined: Tue Nov 04, 2014 12:52 pm
Posts: 3
Yes I am seeing the same problem, but have no answers on how to fix it. If I try to connect directly to a network share (all Win 10 machines), I get the standard "window cannot access ...."

I have very sporadic luck with using the "shared folder option" under Neorouter Network Explorer. I have reinstalled both the server and client software on the computers.

Furthermore, when I let Windows "diagnose" the issue, I get a message about "missing network protocols" which has been documented as a "problem" of Win 10 1511.

No luck beyond that point but I'm still researching and looking.


Top
 Profile  
 
 Post subject: Re: Windows 10 1511 after-reboot issue
PostPosted: Fri Jan 15, 2016 8:14 am 
Offline

Joined: Tue Nov 04, 2014 12:52 pm
Posts: 3
Next update.... ipconfig /all shows neorouter virtual interface disconnected...

On other machines I can ipconfig /release and the interface disconnects (expected) and then ipconfig /renew and the interface connects (again expected).

BUT on the offending machines, that does not work nor does reboot. Tried netcfg -d and rebooted working for now. but there seems to be a bunch of suggestions on fixing this issue some work some don't for some people. YMMV


Top
 Profile  
 
 Post subject: Re: Windows 10 1511 after-reboot issue
PostPosted: Mon Jan 18, 2016 1:15 am 
Offline

Joined: Tue Feb 10, 2009 4:11 am
Posts: 96
sntlewis wrote:
Next update.... ipconfig /all shows neorouter virtual interface disconnected...


You are right, I just saw this problem again tonight, and the neorouter interface's media state was "disconnected".


Attachments:
File comment: media disconnected
nr-disconnected.png
nr-disconnected.png [ 11.33 KiB | Viewed 13531 times ]
Top
 Profile  
 
 Post subject: Re: Windows 10 1511 after-reboot issue
PostPosted: Mon Jan 18, 2016 11:22 am 
Offline

Joined: Mon Jan 18, 2016 11:19 am
Posts: 2
I am also seeing the same on my windows 10 machines. Windows 7 and XP machines are unaffected.


Top
 Profile  
 
 Post subject: Re: Windows 10 1511 after-reboot issue
PostPosted: Mon Jan 25, 2016 8:34 am 
Offline

Joined: Sun Nov 16, 2008 6:41 am
Posts: 1864
Can you try to restart the NR client service from services.msc , it should be fine.

Thanks,
KevinZ - NeoRouter team


Top
 Profile  
 
 Post subject: Re: Windows 10 1511 after-reboot issue
PostPosted: Mon Jan 25, 2016 4:10 pm 
Offline

Joined: Tue Feb 10, 2009 4:11 am
Posts: 96
kevinz wrote:
Can you try to restart the NR client service from services.msc , it should be fine.

Thanks,
KevinZ - NeoRouter team


Kevin,

Thanks for the reply, I will try restarting the service the next time when I see the problem.

However, is it possible that NR checks the network status and tries to fix the issue? I am sure restarting the client service will bring up the interface but it's quite a hassle for normal users.

by the way, I also noticed that occasionally, my linux NR clients sometimes go offline, either because process nrservice is gone, or it's running but somehow nrtap is off. I managed to use monit to restart the client service:

Code:
# check if nrtap link is up
check network nrtap with interface nrtap
   start program = "/etc/init.d/nrservice.sh start" with timeout 60 seconds
   stop  program = "/etc/init.d/nrservice.sh stop"
   if failed link then restart


I haven't found a good 'monit' tool for windows though.


Top
 Profile  
 
 Post subject: Re: Windows 10 1511 after-reboot issue
PostPosted: Wed Jan 27, 2016 10:27 am 
Offline

Joined: Sun Nov 16, 2008 6:41 am
Posts: 1864
Hi ElTopo,

Can you change the Startup Type of NR client service to "Automatic (Delayed Start)"?

Thanks,
KevinZ - NeoRouter team


Top
 Profile  
 
 Post subject: Re: Windows 10 1511 after-reboot issue
PostPosted: Wed Jan 27, 2016 4:13 pm 
Offline

Joined: Tue Feb 10, 2009 4:11 am
Posts: 96
So today I installed a new update from Microsoft and had to reboot Windows 10 Pro (2 systems), and I saw this issue again.

The new Win10 verson: Version 1511 (OS Build 10586.71)

I tried services.msc / restart NR client service, it's not always working at the first time: on one system, restarting NR client activates NR connection, on the other system, I have to restart NR client service twice.


Last edited by ElTopo on Wed Jan 27, 2016 4:21 pm, edited 1 time in total.

Top
 Profile  
 
 Post subject: Re: Windows 10 1511 after-reboot issue
PostPosted: Wed Jan 27, 2016 4:15 pm 
Offline

Joined: Tue Feb 10, 2009 4:11 am
Posts: 96
kevinz wrote:
Hi ElTopo,

Can you change the Startup Type of NR client service to "Automatic (Delayed Start)"?

Thanks,
KevinZ - NeoRouter team


Thanks, I changed the startup type to "Automatic (Delayed Start)" and see...


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 27 posts ]  Go to page 1, 2, 3  Next

All times are UTC - 5 hours


Who is online

Users browsing this forum: Google [Bot] and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to: