Service Initialization Failed
Page 1 of 3

Author:  silviudusa [ Tue Mar 10, 2009 7:08 pm ]
Post subject:  Service Initialization Failed

I am getting the above error message whenever I am trying to log in remotely on a computer. I uninstalled NeoRouter once and re-installed and it worked. Now after a while I am getting the message again.

Author:  kevinz [ Tue Mar 10, 2009 11:41 pm ]
Post subject:  Re: Service Initialization Failed

Thanks silviudusa!

This message means your NeoRouter Client service is not running or stops for some reason at the moment and the Network Explorer cannot connect to it. The Client service will be restarted automatically if it's down, so just try to log on a little bit later if you come cross the message.

If you want to investigate, you can monitor the cliservice.exe process in the task manager and find out if it's down.

KevinZ - NeoRouter team

Author:  medic563 [ Wed Apr 08, 2009 8:21 am ]
Post subject:  Re: Service Initialization Failed

On my system the NeoRouter Client Service is set to start Automatic, but it is always stopped. If I start it manually, it will start and then immediately stop. This has been happening since the update to[1]. I cannot get NeoRouter Network Explorer to work at all on this machine. On my two other machines it works fine, but this is the server. What is the fix?

Author:  kevinz [ Wed Apr 08, 2009 10:06 am ]
Post subject:  Re: Service Initialization Failed

Hi medic563,

Please check as the following steps:
1. Go to the Windows "Services" from Control panel, stop the "NeoRouter Client service" manually.

2. Check the process name "CliService.exe" in "Windows Task Manager". If you find it, just click on the "End Process" button to kill it. Make sure there is no this process running.

3. Open a Command Prompt, cd to the main folder, for example: "C:\Program Files\ZebraNetworkSystems\NeoRouter" on my pc

4. Run command " CliService.exe /app"
if it works, it should show something like this

C:\Program Files\ZebraNetworkSystems\NeoRouter>CliService.exe /app
ROOT\NET\0001 : Restarted
1 device(s) restarted.

but not quit until you press Ctrl+C and it can connect to the server.

If not, let us know what you see.

BTW, only one cliservice instance is running on a computer, if you run it twice, it quit automatically.

KevinZ - NeoRouter team

Author:  medic563 [ Wed Apr 08, 2009 1:48 pm ]
Post subject:  Re: Service Initialization Failed


Thanks for your reply.

I followed your command instructions, the service was not running, so I could not stop it. The process was not running, so I could not kill it. I wend to the cmd line in "C:\Program Files\ZebraNetworkSystems\NeoRouter" on my pc
and typed the command "CliService.exe /app" and I don't get any message in the command line. I watched Windows Task Manager and CliService.exe starts as a process momentarily and then stops.

If I go to Services, Startup type is Automatic and the Status is blank. If I click start, it tries to start and then stops and gives me a message stating that NeoRouter Client Service on local computer started and then stopped. Some Services stop automatically if they have no work to do.

Still get the "Service Initialization Failed" message when signing in to NeoRouter Network Explorer.

FYI, NeoRouter Connection Server is running in Services

OS: Windows XP Home SP 3


Author:  kevinz [ Wed Apr 08, 2009 5:32 pm ]
Post subject:  Re: Service Initialization Failed

Hi medic563,

Can you help me to collect the log file?

Please create a file Log.ini under C:\Program Files\ZebraNetworkSystems\NeoRouter manually and copy&paste the following lines to it.


Save it and run "CliService.exe /app" again. After it stop, it will generate a log file in the same folder, the file name looks like this: CliService_20090408_123456.log. Send the file to so that we can check it.

Don't forget to delete the Log.ini, or it may slow down your NeoRouter.

KevinZ - NeoRouter team

Author:  kevinz [ Sun May 03, 2009 8:00 am ]
Post subject:  Re: Service Initialization Failed

Hi guys,

The bug has been fixed in the latest release 0.9.6.

If you enabled "remember password" and "auto sign in" options, it won't bother you and auto try to connect to the service for 3 times. Then report the error. For most cases, it will detect the service, load it and wait until it's ready, then connect to it silently.

KevinZ - NeoRouter Team

Author:  pippo_lite [ Fri May 29, 2009 2:14 pm ]
Post subject:  Re: Service Initialization Failed

I have the same issue in this post (only the server) and I can't get Neorouter work properly.
I tryed also all you said but nothing at all... I tryed to uninstall and reinstall but is the same, Network Explorer work only on the clients but for the server machine don't.
The server is Windows XP pro sp3, all work fine just 2 hours ago and the server rebooted (I don't know why, no logs about this in windows).
After that Network Explorer stop to work.
I send you my log file as you explain here, I need Neorouter Explorer work for to be applied the firewall rules for the server that run for others sw.
Please, I need help...
Thank You.

Author:  pippo_lite [ Sat May 30, 2009 4:46 am ]
Post subject:  Re: Service Initialization Failed

Hi KevinZ, thank you for your fast replay at my e-mail address.

First: I use to read e-mail in IMAP4 protocol, i successfully read what you write to me but, I don't know why, after 2 access your message was disappeared... mysteriously... bahh, in this period I can't understand a lot of things...

Second: I every time use an administrative account for my access to server, the CliService.exe never change, just stop to work... in the normal use.
I solve the issue like that (perhaps it's usefully for somebody):
I copy the entire folder ZebraNetwokSystems in ..Documents and settings\All user\Application Data\ as a backup
disable firewall, antivirus and Windows Defender
uninstall Neorouter completely, clean temp and registry with Ccleaner
reboot system
install again Neorouter Server (all FW, AV WD always disabled) clean install
change the default proprietary for the services CliService.exe and ConnSvr.exe from Local System with an administrative account with right to start services without log in Windows (I use that sistem for another sw, I don't know why but the producers of that sw only use Local System for sevices with a Windows Server environnement, not for workstations O.S.)
put again in place the NR Database (what i backed-up) and put in exclusion area of AV, FW and WD the 2 folders named ZebraNetworkSystems
reboot system, enable FW, AV and WD and reboot again.

After that all work fine, but I still need to copy the old ClientUI.xml for the "autologin and remember password" work...

That's all. Excuse me for the long post....
Tnx a lot for your work and very fast reply.

Author:  kevinz [ Sat May 30, 2009 8:13 am ]
Post subject:  Re: Service Initialization Failed

Hi pippo_lite,

Thanks for your post. It may help some users having similar issue. But I'd like to explain a little bit.

From your log I can see the cliservice.exe stops when it starts and returns error code 0x80004005, indicating there is an Access Denied error. It means the cliservice would have no enough permission to do some operations (may be rejected by AV software) or conflicts with other applications.

By default NeoRouter Client Service is running under "Local System account", that gives enough permission to it. Of cause you can put it under a specific Windows account by setting the Windows service properties. But it's better to give it GENERIC_READ | GENERIC_WRITE | GENERIC_EXECUTE permissions.

As to the e-mail disappeared, you may want to check your junk mail folder, it may be deleted by your AV software. I double-checked the raw message of the email again and didn't find anything. The content-type is text/plain and we are using a well known third party email service. :)

Let us know if still having problem.

KevinZ - NeoRouter team

Page 1 of 3 All times are UTC - 5 hours
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group