Community


All times are UTC - 5 hours




Post new topic Reply to topic  [ 4 posts ] 
Author Message
 Post subject: after registr. IP addr. is not set on nrtap interf. - Moblin
PostPosted: Tue Jan 04, 2011 10:55 am 
Offline

Joined: Tue Jan 04, 2011 7:28 am
Posts: 2
Hi,

on my Dell Netbook Moblin linux is installed. (http://distrowatch.com/table.php?distribution=moblin)

Upon registering the client from CLI I am getting the "Registered successfully." message, but the IP address of the nrtap interface is not set.

What could be the problem?



from /var/log/syslog :

Code:
Jan  4 15:47:52 dell-desktop kernel: [  251.168305] tun: Universal TUN/TAP device driver, 1.6                                                                                                              Jan  4 15:47:52 dell-desktop connmand[905]: nrtap {create} index 4 type 1 <ETHER>                                                                                                                          Jan  4 15:47:52 dell-desktop kernel: [  251.168320] tun: (C) 1999-2004 Max Krasnyansky <maxk@qualcomm.com>                                                                                                 Jan  4 15:47:52 dell-desktop connmand[905]: nrtap {update} flags 4098 <DOWN>                                                                                                                               Jan  4 15:47:52 dell-desktop connmand[905]: nrtap {newlink} index 4 operstate 2 <DOWN>                                                                                                                     Jan  4 15:47:52 dell-desktop init: Handling misc-device-added event                                                                                                                                        Jan  4 15:47:52 dell-desktop init: Handling net-device-added event                                                                                                                                         Jan  4 15:47:52 dell-desktop connmand[905]: nrtap {add} address 10.0.0.7/8 label nrtap                                                                                                                     Jan  4 15:47:52 dell-desktop connmand[905]: nrtap {del} address 10.0.0.7/8 label nrtap                                                                                                                     Jan  4 15:47:52 dell-desktop connmand[905]: nrtap {newlink} index 4 operstate 2 <DOWN>                                                                                                                     Jan  4 15:47:52 dell-desktop connmand[905]: nrtap {update} flags 69699 <UP,RUNNING,LOWER_UP>                                                                                                               Jan  4 15:47:52 dell-desktop connmand[905]: nrtap {newlink} index 4 operstate 0 <UNKNOWN>                                                                                                                  Jan  4 15:47:52 dell-desktop dhclient: DHCPDISCOVER on nrtap to 255.255.255.255 port 67 interval 4                                                                                                         Jan  4 15:47:54 dell-desktop avahi-daemon[1654]: Registering new address record for fe80::fcfc:64ff:fead:8b79 on nrtap.*.                                                                                  Jan  4 15:47:56 dell-desktop dhclient: DHCPDISCOVER on nrtap to 255.255.255.255 port 67 interval 7                                                                                                         Jan  4 15:48:03 dell-desktop dhclient: DHCPDISCOVER on nrtap to 255.255.255.255 port 67 interval 11                                                                                                        Jan  4 15:48:14 dell-desktop dhclient: DHCPDISCOVER on nrtap to 255.255.255.255 port 67 interval 9


Attachments:
nrclientcmd.log [8.95 KiB]
Downloaded 551 times
Top
 Profile  
 
 Post subject: Re: after registr. IP addr. is not set on nrtap interf. - Moblin
PostPosted: Tue Jan 04, 2011 11:52 am 
Offline

Joined: Sun Nov 16, 2008 6:41 am
Posts: 1873
Hi imrago,

Would you give the results of commands "ifconfig" and "sudo ps aux|grep nrservice"?
Also would you please provide the log file of nrservice instead of nrclientcmd?

Thanks,
KevinZ - NeoRouter team


Top
 Profile  
 
 Post subject: Re: after registr. IP addr. is not set on nrtap interf. - Moblin
PostPosted: Wed Jan 05, 2011 9:48 am 
Offline

Joined: Tue Jan 04, 2011 7:28 am
Posts: 2
Hi Kevin,

>Would you give the results of commands "ifconfig" and "sudo ps aux|grep >nrservice"?
>Also would you please provide the log file of nrservice instead of >nrclientcmd?

the result of"ps aux | grep nrservice" is :

Code:
root      1296  0.0  0.3  96016  3428 ?        Sl   14:27   0:00 /usr/bin/nrservice
root      2025  0.0  0.0   3044   872 pts/0    S+   14:39   0:00 grep --color=auto nrservice


and the rest is in the attached files.

Regards,
Imre


Attachments:
nrclientcmd.log [8.88 KiB]
Downloaded 529 times
nrservice.log [59.97 KiB]
Downloaded 525 times
ifconfig.txt [1.71 KiB]
Downloaded 572 times
Top
 Profile  
 
 Post subject: Re: after registr. IP addr. is not set on nrtap interf. - Moblin
PostPosted: Wed Jan 05, 2011 2:24 pm 
Offline

Joined: Sun Nov 16, 2008 6:41 am
Posts: 1873
Hi imrago,

I went through your log files. It seems like the nrtap (tun device) on your machine didn't get assigned VIP properly.

See below, there is no IPv4 address assigned to it;

nrtap Link encap:Ethernet HWaddr de:0c:39:23:b4:26
inet6 addr: fe80::dc0c:39ff:fe23:b426/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1300 Metric:1
RX packets:3 errors:0 dropped:0 overruns:0 frame:0
TX packets:12 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:500
RX bytes:276 (276.0 B) TX bytes:2220 (2.2 KB)

From the log, I can see your machine has the tun device and the system calls completed successfully.

We didn't test NR on Moblin/MeeGo, though it's a Linux based OS. But we may spend sometime to investigate it later.

Let us know if anyone has the similar issue or any clue.

Thanks,
KevinZ - NeoRouter team


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to: