the network revolves around you™

HOME      PRODUCTS      DOWNLOAD      STORE      DASHBOARD        DOCUMENTS      COMMUNITY MESH

Community


All times are UTC - 5 hours




Post new topic Reply to topic  [ 2 posts ] 
Author Message
 Post subject: How to configure Neorouter android for ftp
PostPosted: Tue May 15, 2012 3:13 pm 
Offline

Joined: Tue May 15, 2012 2:22 pm
Posts: 1
I have Neorouter server running on a Windows 7 machine to which I can connect using Neorouter Android and a VNC client. I also have an Ubuntu machine running vsftpd server, and it's also connected to my NR domain. Vsftpd is running in passive mode and I've assigned it port 2121 for the data connection, port 21 for commands. I've created two static routes on NR Android which current look like this:

FTP:localhost:4021 => 10.0.0.4:21
FTP Data:localhost:9001 => 10.0.0.4:221

Where 10.0.0.4 is the NR address of my Ubuntu machine. I've tried various local ports but until now I keep getting the follow error message.

215 Unix Type: LB
PASV
227 Entering Passive Mode(127,0,0,1,8,73).

Then connection refused. In the server I see [correct username] OK LOGIN: Client "10.0.0.3" which is my android phone.

Using AndFTP on Android

The same connection from my Windows 7 machine, over the NR domain works.

Using FileZilla on Windows 7

Any help will be appreciated.

Thanks


Top
 Profile  
 
 Post subject: Re: How to configure Neorouter android for ftp
PostPosted: Wed May 16, 2012 12:45 pm 
Offline

Joined: Sun Nov 16, 2008 6:41 am
Posts: 1645
Hi jcurtis,

I think you may want to create a Static Port Forward in the NR for Android and proxy the port from phone:2121 to ftp:2121.

FTP:localhost:4021 (using Dynamic Port Forward) => 10.0.0.4:21
FTP Data:localhost:2121 (using Static Port Forward => 10.0.0.4:2121

1.Create the Static Port Forward:
localhost:2121 -> 10.0.0.4:2121

2.The settings on the Vsftpd seems good. As you did, it returns to ftp client with "227 Entering Passive Mode(127,0,0,1,8,73)", i.e. 127.0.0.1:2121. It tells your ftp client connect to localhost:2121, then gets forwarded to 10.0.0.4:2121. And because of this settings, your vsftpd already listens on 2121 and waiting for the data coming in.

Note:
1.Keep the command tunnel using port 21 and using the Dynamic Port Forward, as Android does not allow NR client to listen on a port <= 1024.

2.For the Static Port Forward, please refer to http://www.neorouter.com/android/portforward.html

Let us know if you still have problem.

Thanks,
KevinZ - NeoRouter team


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to: