NeoRouter client won't connect : (hr=0x80820101)
Page 1 of 1

Author:  rebecca232c [ Thu May 17, 2012 9:16 pm ]
Post subject:  NeoRouter client won't connect : (hr=0x80820101)

NeoRouter Network Explorer
Signin failed because connection to server cannot be established.

Having trouble with the windows neorouter client.

System is a modern iMac running the nrserver package. It's working just fine within my local network (behind a TP-Link N300 cable wireless router) - but when I try to connect to it from an external location - a laptop running Win7 ultimate x64 connected via a Vodafone 3G dongle - it fails to connect with the above error.

The craziest thing though - is that it's perfectly able to connect with the configuration explorer and manage the server (or so it appears) - but the client will not connect at this point.

I've noticed that others have a similar problem (same code) but the suggestions there don't seem to work!

Even turning off the windows firewall completely doesn't help?

Author:  kevinz [ Thu May 17, 2012 9:49 pm ]
Post subject:  Re: NeoRouter client won't connect : (hr=0x80820101)

Hi rebecca232c,

The error code 0x80820101 means Server cannot process client connect request. It's caused by various reasons. For example, your trial license expired, server has problem to access the database or invalid message sent to the server.

Would you try it from your home LAN again see if you can connect to the server or not?

There is nothing to do with the firewall. The Configuration Explorer can always connect to the server, no matter the license expired or not. If it can connect to the server, your physical network should be fine.

KevinZ - NeoRouter team

Author:  rebecca232c [ Mon May 21, 2012 6:18 pm ]
Post subject:  Re: NeoRouter client won't connect : (hr=0x80820101)

Hi Kevin,

You won't believe this - I managed to get the netbook connecting via the 3G dongle and it goes in now like a dream each time I start the beast up. However, I've just tried adding a laptop to the VPN and it's arguing in the same way.

Stupidly - I forgot to write down what I did to make it work! So... I've done it once - I can do it again.....

So - firewall not an issue - that's good - I can ignore that... and the installer puts the right rules in there anyway. I modified them specifically for port 32976 - just to be on the safe side (I don't like any old ports being open....). The license issue isn't an issue - I'm using the free client/server and it never expires - so it can't be that. I've got the server on a fixed IP and the firewall knows that address and port.... I've also reinstalled the client as well... and that's made no difference... wonder what's left......?

Oh - the server is currently an iMac - and the clients are either windows 7 or linux. I'll report back when I've found some more information....

NB - I've just added another desktop to the VPN - and when that went in right away, I checked the network explorer... and it's showing the laptop now - but as off-line. Trying to login from the Tosh again hasn't worked - yet...

I do seem to remember seeing a message about sockets... but I'm not a specialist on networks......?

Author:  kevinz [ Tue May 22, 2012 10:06 am ]
Post subject:  Re: NeoRouter client won't connect : (hr=0x80820101)

Hi rebecca232c,

If you can provide the log file of the NR server, it would be helpful for us to investigate the issue.

About generating log file, please refer to ... og_file.3F

You can send the log file to our support(at) email account.

KevinZ - NeoRouter team

Author:  rebecca232c [ Wed Jul 04, 2012 8:34 pm ]
Post subject:  Re: NeoRouter client won't connect : (hr=0x80820101)

Ok - tried again with a new domain name (a test domain) - on a Toshiba with Win7 Ultimate - and this time..... I've got the log and I've sent it to the support email address.

What's been driving me crazy with this is that last time, I left the PC alone for a few days and when I powered it up, the client went in immediately - with no changes having been made to the cable router at all. There had been no need for any changes as it was working fine with the neorouter server running on my iMac.

The attempted installation today and the resulting log have been created while the rest of the network - except for my linux webserver - has been powered down for house wiring. So - there's nothing else there to cause any problems!

Eventually I suppose I'll move the server to my webserver machine so that it's on 24/7....... but that comes later after we've worked out what is going on with this problem!

Author:  kevinz [ Fri Jul 06, 2012 8:28 am ]
Post subject:  Re: NeoRouter client won't connect : (hr=0x80820101)

Hi rebecca232c,

Thanks for your information.

Based on your log file, I found one of your NR clients connected to the server, but rejected.
2012-07-04 01:06:19,930|01688|01992| | +[CDBComputer::Connect]
2012-07-04 01:06:19,930|01688|01992| | -[CDBComputer::Connect](hr=0x8081db91)
2012-07-04 01:06:19,930|01688|01992|I| Computer HST2 fail to connect
2012-07-04 01:06:19,930|01688|01992| | -[ComputerHandler::ConnectActual](hr=0x8081db91)

The error code 0x8081db91 means NR server cannot find the computer in its database so cannot accept it. If it's your machine, please run Configuration Explorer, delete it from the computer list, if it exists. Then go to the machine , run either Network Explorer or nrclientcmd to sign in again to register the machine to the NRserver. Then it should be fine.

As you may know NR client use MAC address of the primary network adapter to identify itself while logging in or connecting to the NR server, if you changed your network adapter, it may cause the issue.

Let us know if you still have problem.

KevinZ - NeoRouter team

Author:  markd89 [ Fri Oct 26, 2012 12:07 pm ]
Post subject:  Re: NeoRouter client won't connect : (hr=0x80820101)


I'm getting the same error on my XP machine (but not my Win7) machine.

I emailed the log just now and look forward to your suggestions.


Author:  rechmp [ Mon Jan 14, 2013 8:20 am ]
Post subject:  Re: NeoRouter client won't connect : (hr=0x80820101)

Hello guys.
I have same problems several times. And now i think i know how to log normally.
That error occurs when You create new user on server and trying to log in.
I have same problem after that and it can be fixed by rebooting system (restarting nrserver did not helped me).
May be on other Os's it will not work, but my nr server working on Ubuntu Server, and it helps me.

Page 1 of 1 All times are UTC - 5 hours
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group