Community


All times are UTC - 5 hours




Post new topic Reply to topic  [ 4 posts ] 
Author Message
 Post subject: NeoRouter stuck on acquiring address
PostPosted: Thu Dec 20, 2012 12:45 am 
Offline

Joined: Thu Dec 20, 2012 12:27 am
Posts: 2
Hi,
I have a friend who runs a neorouter server and about 8 different friends of mine are all able to connect to the server (including my windows 7 x64 laptop) but my XP Pro x64 desktop will not properly connect.

In the network connections, the NeoRouter Connection status is "Acquiring Network Connection".
The NeoRouter Client Service is started. Restarting the service or my desktop does not help. Uninstalling, rebooting, and then reinstalling NeoRouter 1.7.1.3430 also does not solve the issue.
The NeoRouter Network Explorer seems to connect. It lists my own desktop as well as all the other computers. It even says that my desktop has a proper IP address. I can't however ping myself or any other computer in the list.
When I do a IPCONFIG /all it tells me that the NeoRouter Connection has an IP address of 169.254.176.223 with a 255.255.0.0 subnet which is obviously not correct and does not match the proper IP that the Network Explorer is listing.
In cmd, if I go to "C:\Program Files (x86)\ZebraNetworkSystems\NeoRouter\Driver" and type in "tapinstall.exe status nrtap" I get:
ROOT\NET\0000
Name: NeoRouter Virtual Network Interface
Driver is running.
1 matching device(s) found.

Any ideas or things I can try? I don't think it is the server as all the other computers can connect including my laptop when I'm on the same home network as my desktop.

Thanks in advance!
-Grog


Top
 Profile  
 
 Post subject: Re: NeoRouter stuck on acquiring address
PostPosted: Thu Dec 20, 2012 8:06 am 
Offline

Joined: Sun Nov 16, 2008 6:41 am
Posts: 1868
Hi grogthegreat,

It looks like NR client service failed to assign the VIP to the virtual adapter. Would you check this?

1.Check if netsh command available on that machine?

2.You can try to manually set the VIP on the NR virtual adapter in the Windows > Panel > Network settings, see if it works. At least this confirms it's caused by assigning VIP.

Let us know if you still have problem.

Thanks,
KevinZ - NeoRouter team


Top
 Profile  
 
 Post subject: Re: NeoRouter stuck on acquiring address
PostPosted: Thu Dec 20, 2012 9:36 pm 
Offline

Joined: Thu Dec 20, 2012 12:27 am
Posts: 2
Thanks for the reply.

I'm not sure what the proper method of testing netsh is but when I open the cmd prompt and entered "netsh" I got a error popup that said:

netsh.exe - Entry Point Not Found
The procedure entry point MigrateWinsockConfiguration could not be located in the dynamic link library MSWSOCK.dll

At this point the cmd prompt displays:

The following helper DLL cannot be loaded: IFMON.DLL
netsh>

Is this good or bad?

The good news is that when I manually assign my NeoRouter network connection the same IP address (with a 255.0.0.0 subnet mask) as what the NeoRouter Network Explorer claims my desktop should have, it works. Is a workaround that I can live with although I would love it if the actual issue is resolved.


Last edited by grogthegreat on Fri Dec 21, 2012 8:46 pm, edited 1 time in total.

Top
 Profile  
 
 Post subject: Re: NeoRouter stuck on acquiring address
PostPosted: Fri Dec 21, 2012 11:33 am 
Offline

Joined: Sun Nov 16, 2008 6:41 am
Posts: 1868
Hi grogthegreat,

It's good to find out the root cause. Some dlls used by netsh.exe are missing on your machine.

Please make sure netsh working.

Thanks,
Kevinz - NeoRouter team


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 4 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron