Community


All times are UTC - 5 hours




Post new topic Reply to topic  [ 28 posts ]  Go to page Previous  1, 2, 3
Author Message
 Post subject: Re: Error running NeoRouter on Mac OS 10.4 PowerPC
PostPosted: Sat Dec 19, 2009 3:24 pm 
Offline

Joined: Sat Dec 19, 2009 3:15 pm
Posts: 3
I have the same problem on an Intel MacBook running Tiger. I have this problem with a fresh install of 0.9.9. I never had an earlier version installed. I tried to follow the instructions mentioned. All of the files are in the correct folders. When I try to run nrclientcmd straight from the command line, I type /Library/NeoRouter/nrclientcmd and all it says is Bus error. So this problem is not solved yet! =)


Top
 Profile  
 
 Post subject: Re: Error running NeoRouter on Mac OS 10.4 PowerPC
PostPosted: Sat Dec 19, 2009 4:32 pm 
Offline

Joined: Mon Dec 22, 2008 10:19 pm
Posts: 436
Hi Knightofiam,

Since you have an Intel + Tiger mac, this is a different issue. We have tested PPC + Tiger and the bug should have been fixed.

If you are using neorouter packages for x86, can you try the one for powerpc? The powerpc packages are compiled on a PPC + Tiger, while the x86 packages are compiled on an Intel + Leopard. So the powerpc version might work for you.

Unfortunately we do not have an Intel + Tiger machine. It is very difficult to get hold of one such computer, because Apple only released such combination for a little more than a year (from early 2006 - mid 2007). Have you considered upgrading to Leopard?

_________________
Luke - NeoRouter Team


Top
 Profile  
 
 Post subject: Re: Error running NeoRouter on Mac OS 10.4 PowerPC
PostPosted: Sun Dec 20, 2009 12:27 pm 
Offline

Joined: Sat Dec 19, 2009 3:15 pm
Posts: 3
luke wrote:
If you are using neorouter packages for x86, can you try the one for powerpc? The powerpc packages are compiled on a PPC + Tiger, while the x86 packages are compiled on an Intel + Leopard. So the powerpc version might work for you.


Unfortunately, the installer will not allow me to install the PPC packages, so I cannot test this. Is there any hope?


Top
 Profile  
 
 Post subject: Re: Error running NeoRouter on Mac OS 10.4 PowerPC
PostPosted: Sun Dec 20, 2009 12:47 pm 
Offline

Joined: Sat Dec 19, 2009 3:15 pm
Posts: 3
Well, I just found out that I can upgrade to Snow Leopard for only $29. So that's probably the best option at this point, right?


Top
 Profile  
 
 Post subject: Re: Error running NeoRouter on Mac OS 10.4 PowerPC
PostPosted: Sun Dec 20, 2009 1:09 pm 
Offline

Joined: Mon Dec 22, 2008 10:19 pm
Posts: 436
That's great!
Yes, we have fully tested on Snow Leopard.

_________________
Luke - NeoRouter Team


Top
 Profile  
 
 Post subject: Re: Error running NeoRouter on Mac OS 10.4 PowerPC
PostPosted: Tue Dec 22, 2009 3:03 pm 
Offline

Joined: Fri Jun 26, 2009 11:37 am
Posts: 13
Hey Luke, sorry for the delay - holidays sure get crazy. :-)

I tried your suggested steps from 12/08 and still no luck. The install still says the it was successful and a file did show up in Receipts, but nothing appeared in /Library/NeoRouter.

I'll try again tonight on my friend's Mac.

Thanks for your help!

Jon-Mikel


Top
 Profile  
 
 Post subject: Re: Error running NeoRouter on Mac OS 10.4 PowerPC
PostPosted: Tue Dec 22, 2009 5:16 pm 
Offline

Joined: Mon Dec 22, 2008 10:19 pm
Posts: 436
If the package still does not work, please try the manual install method discussed in the following thread so that you can start using NeoRouter.

viewtopic.php?f=8&t=2316&start=10

Sorry about the inconvenience.

_________________
Luke - NeoRouter Team


Top
 Profile  
 
 Post subject: Re: Error running NeoRouter on Mac OS 10.4 PowerPC
PostPosted: Wed Dec 23, 2009 3:28 pm 
Offline

Joined: Fri Jun 26, 2009 11:37 am
Posts: 13
Luke,

The package install failed on my friends machine as well but the manual install from the other thread worked great. If I have any problems with it on the other machine I'll be sure to let you know.

Thanks for all your help!

Jon-Mikel

Note: I had to make a few tweaks to the manual install on my 10.4 powerpc box as follows:
Code:
- Step 2 needed neorouterclient.pkg case changed to NeoRouterClient.pkg
- Step 4 needed
  - neorouterclientlaunchdaemons.pkg case changed to NeoRouterClientLaunchDaemons.pkg
  - cp nrservice.plist changed to sudo cp nrservice.plist
- Step 5 changed to
  - cd nrclient-0.9-9.1528-powerpc.mpkg/Contents/Resources
  - sudo ./postflight

I also did the following:
- Step 6 /Library/NeoRouter/nrclientcmd (to test login)
- Step 7 reboot (to ensure service starts correctly on reboot)


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 28 posts ]  Go to page Previous  1, 2, 3

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 4 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron