Community


All times are UTC - 5 hours




Post new topic Reply to topic  [ 5 posts ] 
Author Message
 Post subject: Unable to connect to windows/samba shares
PostPosted: Wed Nov 25, 2009 6:33 pm 
Offline

Joined: Wed Nov 25, 2009 6:17 pm
Posts: 5
Hey guys,

Firstly I'd like to say thanks for makeing a zero config vpn solution that works on mac, linix and windows.

Now onto the problem I've been having.

We use neo-router at work to allow our staff to work from home etc. Recently on of the guys updated from ubuntu 9.04 -> 9.10 and can no longer reach our samba shares via the vpn.

We can ping both ways and the user has file sharing enabled on his account in neo-router. Viewing web content across the vpn also works. Connecting to windows/samba shares worked in 9.04. Any idea on how to work around this? I'm gonna have a look at the ubuntu site in a sec and see if anyone else is having this problem.


*edit* forgot to mention that the 9.10 box can view the shares directly if it is plugged into the same subnet.


Cheers
Owen


Top
 Profile  
 
 Post subject: Re: Unable to connect to windows/samba shares
PostPosted: Wed Nov 25, 2009 10:41 pm 
Offline

Joined: Sun Nov 16, 2008 6:41 am
Posts: 1869
Hi owenp,

Since the two computers can ping each other over NeoRouter, the samba should work too.

Can you try to telnet tcp/445 port from the ubuntu to the samba server and check the ACL and firewall?

Thanks,
KevinZ - NeoRouter team


Top
 Profile  
 
 Post subject: Re: Unable to connect to windows/samba shares
PostPosted: Wed Nov 25, 2009 11:06 pm 
Offline

Joined: Wed Nov 25, 2009 6:17 pm
Posts: 5
Hi Kevin,

Telnet to port 445 just times out. If I do it direct, it connects within a second.

No firewall running on either machine and the ACL seems to be correct.

Any other ideas?

Thanks
Owen


Top
 Profile  
 
 Post subject: Re: Unable to connect to windows/samba shares
PostPosted: Thu Nov 26, 2009 9:29 am 
Offline

Joined: Sun Nov 16, 2008 6:41 am
Posts: 1869
Can you disable the firewall in NeoRouter for the "Default User" for the ubuntu (samba server) and telnet to 445 again?

Thanks,
KevinZ - NeoRouter team


Top
 Profile  
 
 Post subject: Re: Unable to connect to windows/samba shares
PostPosted: Fri Dec 18, 2009 6:47 pm 
Offline

Joined: Wed Nov 25, 2009 6:17 pm
Posts: 5
Sorry for not following this up earlier.

We ended up downgrading to ubuntu 9.04 due to other problems we were having so unfortunately I can not test this currently.

Owen


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron