Community


All times are UTC - 5 hours




Post new topic Reply to topic  [ 15 posts ]  Go to page 1, 2  Next
Author Message
 Post subject: Bad packages for OS X?
PostPosted: Sun Dec 06, 2009 1:24 pm 
Offline

Joined: Wed Nov 18, 2009 3:43 pm
Posts: 14
Both the client and the server packages for OS X (0.9.9) report "Installation Failed" with no files being found to install.

Something seems wrong. . .

--George


Top
 Profile  
 
 Post subject: Re: Bad packages for OS X?
PostPosted: Sun Dec 06, 2009 4:19 pm 
Offline

Joined: Sun Nov 16, 2008 6:41 am
Posts: 1869
Hi gandrews,

Can you compare the md5 of your downloaded files with our website?
Which files (x86 or ppc) you've got have problem?

Thanks,
KevinZ - NeoRouter team


Top
 Profile  
 
 Post subject: Re: Bad packages for OS X?
PostPosted: Mon Dec 07, 2009 12:55 pm 
Offline

Joined: Wed Nov 18, 2009 3:43 pm
Posts: 14
I redownloaded the x86 packages, confirmed the MD5 codes, and attempted to install. Same issue: "The installation failed."

No software found to install, or something like that, was the specific error.

Interestingly, the PPC packages would install properly, but they do not work on my system.

--George


Top
 Profile  
 
 Post subject: Re: Bad packages for OS X?
PostPosted: Mon Dec 07, 2009 3:46 pm 
Offline

Joined: Mon Dec 22, 2008 10:19 pm
Posts: 436
Hi George,

Thanks for reporting. Please help provide more info on the error you see.

- OS type, CPU type
- Are you installing to default location and use default settings?
- At which step during the installation do you see the error?
- can you use the following command line to install the package and send me the log?
Code:
sudo installer -pkg nrclient-*-*.mpkg -volinfo -pkginfo -verbose -dumplog > installlog.txt

http://developer.apple.com/mac/library/ ... ler.8.html
- if you have not, can you try remove the package first (sudo /Library/NeoRouter/rmnrclient.cmd) and ensure nrservice is not running (ps -A | grep nrservice)?

Thanks,

_________________
Luke - NeoRouter Team


Top
 Profile  
 
 Post subject: Re: Bad packages for OS X?
PostPosted: Mon Dec 07, 2009 9:53 pm 
Offline

Joined: Mon Dec 22, 2008 10:19 pm
Posts: 436
Hi George,

One more thing to try is to remove the receipts of old packages.
On Snow Leopard, you can use pkgutil to remove receipts.
Code:
    1. Use "pkgutil --packages" to list all installed packages, and you will find package names with "NeoRouter" prefix.
    2. sudo pkgutil --forget NeoRouter.nrclient.pkg
        sudo pkgutil --forget NeoRouter.nrclient.startupitems.pkg
        sudo pkgutil --forget NeoRouter.nrclient.launchdaemons.pkg

        if you have installed server, remove them as well:
        sudo pkgutil --forget NeoRouter.nrserver.pkg
        sudo pkgutil --forget NeoRouter.nrserver.startupitems.pkg
        sudo pkgutil --forget NeoRouter.nrserver.launchdaemons.pkg
    3. sudo /Library/NeoRouter/rmnrclient.sh
        sudo /Library/NeoRouter/rmnrserver.sh


On Leopard and Tiger, the receipts are kept under /Library/Receipts/.
Code:
    1. sudo rm -rf /Library/Receipts/NeoRouter*.pkg
    2. sudo /Library/NeoRouter/rmnrclient.sh
        sudo /Library/NeoRouter/rmnrserver.sh


Now your computer should be clean. Reboot just to be sure. Then install NeoRouter 0.9.9. Hope this will work.

Thanks,

_________________
Luke - NeoRouter Team


Top
 Profile  
 
 Post subject: Re: Bad packages for OS X?
PostPosted: Mon Dec 07, 2009 10:39 pm 
Offline

Joined: Wed Nov 18, 2009 3:43 pm
Posts: 14
My system is an iMac w/4 GB RAM, 2.8 GHz Intel Core Duo, running Snow Leopard (v. 10.6.2) with the latest updates.

I am simply double-clicking on the mpkg file and stepping through the installation GUI with no modifications to the defaults. The installer steps past the point of asking for a drive location (my startup drive is the default), and fails on the step marked "Installation" just after asking for my password.

Here are the MD5 confirmations:
Georges-iMac:~ gandrews$ cd Desktop
Georges-iMac:Desktop gandrews$ md5 nrserver-0.9.9.1528-osx-x86.tar.gz
MD5 (nrserver-0.9.9.1528-osx-x86.tar.gz) = 2f4c73bb252fac77ff2798c245a56c5a
Georges-iMac:Desktop gandrews$ md5 nrclient-0.9.9.1528-osx-x86.tar.gz
MD5 (nrclient-0.9.9.1528-osx-x86.tar.gz) = 26ee3b1ab42b1d754264baaa9a18bdc7
Georges-iMac:Desktop gandrews$

Interesting set of messages at the command line (why is NeoRouter stumbling across these other applications?):
Georges-iMac:Desktop gandrews$ sudo installer -pkg nrclient-*-*.mpkg -volinfo -pkginfo -verbose -dumplog > installlog.txt
2009-12-07 19:01:21.133 installer[20637:3603] PackageKit: *** Missing bundle identifier: /Library/Receipts/CC Audio Unit plug-in.pkg
2009-12-07 19:01:21.136 installer[20637:3603] PackageKit: *** Missing bundle identifier: /Library/Receipts/CC Support Files.pkg
2009-12-07 19:01:21.137 installer[20637:3603] PackageKit: *** Missing bundle identifier: /Library/Receipts/CC VST plug-in.pkg
2009-12-07 19:01:21.142 installer[20637:3603] PackageKit: *** Missing bundle identifier: /Library/Receipts/CPDEMO Audio Unit plug-in.pkg
2009-12-07 19:01:21.143 installer[20637:3603] PackageKit: *** Missing bundle identifier: /Library/Receipts/CPDEMO Support Files.pkg
2009-12-07 19:01:21.144 installer[20637:3603] PackageKit: *** Missing bundle identifier: /Library/Receipts/CPDEMO VST plug-in.pkg
2009-12-07 19:01:21.150 installer[20637:3603] PackageKit: *** Missing bundle identifier: /Library/Receipts/CSDEMO Audio Unit plug-in.pkg
2009-12-07 19:01:21.152 installer[20637:3603] PackageKit: *** Missing bundle identifier: /Library/Receipts/CSDEMO Support Files.pkg
2009-12-07 19:01:21.153 installer[20637:3603] PackageKit: *** Missing bundle identifier: /Library/Receipts/CSDEMO VST plug-in.pkg
2009-12-07 19:01:21.388 installer[20637:3603] PackageKit: *** Missing bundle identifier: /Library/Receipts/Flip4Mac QuickTime Components.pkg
2009-12-07 19:01:21.390 installer[20637:3603] PackageKit: *** Missing bundle identifier: /Library/Receipts/Flip4Mac Web Plugins.pkg
2009-12-07 19:01:22.169 installer[20637:3603] PackageKit: *** Missing bundle identifier: /Library/Receipts/LightSpeed Demo.pkg
2009-12-07 19:01:22.170 installer[20637:3603] PackageKit: *** Missing bundle identifier: /Library/Receipts/LightSpeed Resources.pkg
2009-12-07 19:01:22.176 installer[20637:3603] PackageKit: *** Missing bundle identifier: /Library/Receipts/NeoOffice-2.2.2-Intel.pkg
2009-12-07 19:01:22.177 installer[20637:3603] PackageKit: *** Missing bundle identifier: /Library/Receipts/NeoOffice-2.2.2-Patch-11-Intel.pkg
2009-12-07 19:01:22.178 installer[20637:3603] PackageKit: *** Missing bundle identifier: /Library/Receipts/NeoOffice-2.2.3-Intel.pkg
2009-12-07 19:01:22.179 installer[20637:3603] PackageKit: *** Missing bundle identifier: /Library/Receipts/NeoOffice-2.2.3-Patch-1-Intel.pkg
2009-12-07 19:01:22.180 installer[20637:3603] PackageKit: *** Missing bundle identifier: /Library/Receipts/NeoOffice-2.2.3-Patch-3-Intel.pkg
2009-12-07 19:01:22.181 installer[20637:3603] PackageKit: *** Missing bundle identifier: /Library/Receipts/NeoOffice-2.2.3-Patch-5-Intel.pkg
2009-12-07 19:01:22.182 installer[20637:3603] PackageKit: *** Missing bundle identifier: /Library/Receipts/NeoOffice-2.2.4-Intel.pkg
2009-12-07 19:01:22.183 installer[20637:3603] PackageKit: *** Missing bundle identifier: /Library/Receipts/NeoOffice-2.2.4-Patch-2-Intel.pkg
2009-12-07 19:01:22.184 installer[20637:3603] PackageKit: *** Missing bundle identifier: /Library/Receipts/NeoOffice-2.2.4-Patch-3-Intel.pkg
2009-12-07 19:01:22.185 installer[20637:3603] PackageKit: *** Missing bundle identifier: /Library/Receipts/NeoOffice-2.2.4-Patch-5-Intel.pkg
2009-12-07 19:01:22.187 installer[20637:3603] PackageKit: *** Missing bundle identifier: /Library/Receipts/NeoOffice-2.2.5-Intel.pkg
2009-12-07 19:01:22.188 installer[20637:3603] PackageKit: *** Missing bundle identifier: /Library/Receipts/NeoOffice-2.2.5-Patch-1-Intel.pkg
2009-12-07 19:01:22.189 installer[20637:3603] PackageKit: *** Missing bundle identifier: /Library/Receipts/NeoOffice-2.2.5-Patch-2-Intel.pkg
2009-12-07 19:01:22.190 installer[20637:3603] PackageKit: *** Missing bundle identifier: /Library/Receipts/NeoOffice-2.2.5-Patch-7-Intel.pkg
Georges-iMac:Desktop gandrews$

The installlog.txt is less informative:

Package information:

Package : NeoRouter Client
Status : MetaPackage
Will Restart : NO
Size : 2560 KB
Must Authenticate : NO
Title : NeoRouter Client
Description :
Message : MetaPackage information only, it is not installed

Package : nrclient
Status : Install
Will Restart : NO
Size : 2560 KB
Must Authenticate : YES
Title : nrclient
Description :
Message :

Volume information:

Status : Enabled
Volume : Macintosh HD
Size : 749.81 GB
MountPoint : /
Device Node : disk0s2
FileSystem Kind : Journaled HFS+
Message :

Honestly, I'd suggest you try rebuilding the installation packages. From here, at least, it looks like the packages are faulty. nrserver is only 2/3 the size of the prior version (606 kb unpacked vs. over 900 kb for 0.9.8). Did you really significantly reduce the size of the package in this new release? That's a huge decrease!

--George.


Top
 Profile  
 
 Post subject: Re: Bad packages for OS X?
PostPosted: Mon Dec 07, 2009 10:46 pm 
Offline

Joined: Wed Nov 18, 2009 3:43 pm
Posts: 14
I guess we were both posting at the same time.

I saw your second after I made my last tests. I tried running all of the "forget" statements (got that weird list of packages again) and re-ran the installations.

Same result.

--George


Top
 Profile  
 
 Post subject: Re: Bad packages for OS X?
PostPosted: Mon Dec 07, 2009 10:51 pm 
Offline

Joined: Mon Dec 22, 2008 10:19 pm
Posts: 436
0.9.9 binaries are not universal, so they are about half the size compared to 0.9.8 universal binaries.

I will look into this more and try to reproduce in our lab.

_________________
Luke - NeoRouter Team


Top
 Profile  
 
 Post subject: Re: Bad packages for OS X?
PostPosted: Mon Dec 07, 2009 11:11 pm 
Offline

Joined: Wed Nov 18, 2009 3:43 pm
Posts: 14
Hello again.

(Bad form to reply to my own posts, I know, but I don't get to work on this stuff as often as I'd like.)

So, my guess about the packages being faulty was wrong, because I was able to install 0.9.9 on my wife's system (almost identical) with no problems.

Hmmm.

The 0.9..8 packages do install okay, but something is still amiss.

Still looking. . .

--George


Top
 Profile  
 
 Post subject: Re: Bad packages for OS X?
PostPosted: Mon Dec 07, 2009 11:14 pm 
Offline

Joined: Mon Dec 22, 2008 10:19 pm
Posts: 436
The command I gave you was probably not accurate. Here is the command I use and the result. Can you compare and see if you can find anything interesting?

lukes-macbook:Downloads luke$ sudo installer -pkg nrclient-0.9-9.1528-i386.mpkg -target / -dumplog
installer: Package name is NeoRouter Client
installer: Upgrading at base path /
installer[300]: -[IFDInstallController(Private) _buildInstallPlan]: location = file://localhost
installer[300]: -[IFDInstallController(Private) _buildInstallPlan]: file://localhost/Users/luke/Downloads/n ... aemons.pkg
installer[300]: -[IFDInstallController(Private) _buildInstallPlan]: file://localhost/Users/luke/Downloads/n ... client.pkg
installer[300]: Will use PK session
installer[300]: Starting installation:
installer[300]: Configuring volume "Macintosh HD_2"
installer[300]: Preparing disk for local booted install.
installer[300]: Free space on "Macintosh HD_2": 143.42 GB (143419854848 bytes).
installer[300]: Create temporary directory "/var/folders/zz/zzzivhrRnAmviuee+++++++++++/-Tmp-//Install.300A3ZjHl"
installer[300]: IFPKInstallElement (2 packages)
installer[300]: PackageKit: ----- Begin install -----
installer[300]: PackageKit: request=PKInstallRequest <2 packages, destination=/>
installer[300]: PackageKit: packages=(
"PKJaguarPackage <file://localhost/Users/luke/Downloads/nrclient-0.9-9.1528-i386.mpkg/Contents/Packages/neorouterclientlaunchdaemons.pkg>",
"PKJaguarPackage <file://localhost/Users/luke/Downloads/nrclient-0.9-9.1528-i386.mpkg/Contents/Packages/neorouterclient.pkg>"
)
2009-12-07 20:07:35.087 installer[300:772b] using receipt prefix of Library/LaunchDaemons
2009-12-07 20:07:35.102 installer[300:772b] using receipt prefix of Library/NeoRouter/
installer[300]: PackageKit: Extracting /Users/luke/Downloads/nrclient-0.9-9.1528-i386.mpkg/Contents/Packages/neorouterclientlaunchdaemons.pkg/Contents/Archive.pax.gz (destination=/var/folders/zz/zzzivhrRnAmviuee+++++++++++/-Tmp-/PKInstallSandbox-tmp/Root/Library/LaunchDaemons, uid=0)
installer[300]: PackageKit: Extracting /Users/luke/Downloads/nrclient-0.9-9.1528-i386.mpkg/Contents/Packages/neorouterclient.pkg/Contents/Archive.pax.gz (destination=/var/folders/zz/zzzivhrRnAmviuee+++++++++++/-Tmp-/PKInstallSandbox-tmp/Root/Library/NeoRouter, uid=0)
installer[300]: PackageKit: Executing script "./preupgrade" in /Users/luke/Downloads/nrclient-0.9-9.1528-i386.mpkg/Contents/Packages/neorouterclient.pkg/Contents/Resources
installer[300]: ./preupgrade: No matching processes were found
installer[300]: PackageKit: Shoving /var/folders/zz/zzzivhrRnAmviuee+++++++++++/-Tmp-/PKInstallSandbox-tmp/Root (1 items) to /
installer[300]: PackageKit: Executing script "./postflight" in /Users/luke/Downloads/nrclient-0.9-9.1528-i386.mpkg/Contents/Packages/neorouterclient.pkg/Contents/Resources
installer[300]: Installed "NeoRouter Client" ()
installer[300]: PackageKit: ----- End install -----
installer[300]: Running install actions
installer[300]: Removing temporary directory "/var/folders/zz/zzzivhrRnAmviuee+++++++++++/-Tmp-//Install.300A3ZjHl"
installer[300]: Finalize disk "Macintosh HD_2"
installer[300]: Notifying system of updated components
installer[300]:
installer[300]: **** Summary Information ****
installer[300]: Operation Elapsed time
installer[300]: -----------------------------
installer[300]: disk 0.01 seconds
installer[300]: script 0.00 seconds
installer[300]: zero 0.01 seconds
installer[300]: install 2.00 seconds
installer[300]: -total- 2.03 seconds
installer[300]:
installer: The upgrade was successful.

_________________
Luke - NeoRouter Team


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 15 posts ]  Go to page 1, 2  Next

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron