Community


All times are UTC - 5 hours




Post new topic Reply to topic  [ 15 posts ]  Go to page Previous  1, 2
Author Message
 Post subject: Re: Bad packages for OS X?
PostPosted: Tue Dec 08, 2009 12:57 am 
Offline

Joined: Wed Nov 18, 2009 3:43 pm
Posts: 14
Georges-iMac:Downloads gandrews$ sudo installer -pkg nrclient-0.9-9.1528-i386.mpkg -target / -dumplog
2009-12-07 21:23:38.469 installer[2613:4207] PackageKit: *** Missing bundle identifier: /Library/Receipts/CC Audio Unit plug-in.pkg
2009-12-07 21:23:38.472 installer[2613:4207] PackageKit: *** Missing bundle identifier: /Library/Receipts/CC Support Files.pkg
2009-12-07 21:23:38.473 installer[2613:4207] PackageKit: *** Missing bundle identifier: /Library/Receipts/CC VST plug-in.pkg
2009-12-07 21:23:38.478 installer[2613:4207] PackageKit: *** Missing bundle identifier: /Library/Receipts/CPDEMO Audio Unit plug-in.pkg
2009-12-07 21:23:38.479 installer[2613:4207] PackageKit: *** Missing bundle identifier: /Library/Receipts/CPDEMO Support Files.pkg
2009-12-07 21:23:38.480 installer[2613:4207] PackageKit: *** Missing bundle identifier: /Library/Receipts/CPDEMO VST plug-in.pkg
2009-12-07 21:23:38.485 installer[2613:4207] PackageKit: *** Missing bundle identifier: /Library/Receipts/CSDEMO Audio Unit plug-in.pkg
2009-12-07 21:23:38.486 installer[2613:4207] PackageKit: *** Missing bundle identifier: /Library/Receipts/CSDEMO Support Files.pkg
2009-12-07 21:23:38.487 installer[2613:4207] PackageKit: *** Missing bundle identifier: /Library/Receipts/CSDEMO VST plug-in.pkg
2009-12-07 21:23:38.492 installer[2613:4207] PackageKit: *** Missing bundle identifier: /Library/Receipts/Flip4Mac QuickTime Components.pkg
2009-12-07 21:23:38.493 installer[2613:4207] PackageKit: *** Missing bundle identifier: /Library/Receipts/Flip4Mac Web Plugins.pkg
2009-12-07 21:23:38.561 installer[2613:4207] PackageKit: *** Missing bundle identifier: /Library/Receipts/LightSpeed Demo.pkg
2009-12-07 21:23:38.562 installer[2613:4207] PackageKit: *** Missing bundle identifier: /Library/Receipts/LightSpeed Resources.pkg
2009-12-07 21:23:38.570 installer[2613:4207] PackageKit: *** Missing bundle identifier: /Library/Receipts/NeoOffice-2.2.2-Intel.pkg
2009-12-07 21:23:38.571 installer[2613:4207] PackageKit: *** Missing bundle identifier: /Library/Receipts/NeoOffice-2.2.2-Patch-11-Intel.pkg
2009-12-07 21:23:38.573 installer[2613:4207] PackageKit: *** Missing bundle identifier: /Library/Receipts/NeoOffice-2.2.3-Intel.pkg
2009-12-07 21:23:38.574 installer[2613:4207] PackageKit: *** Missing bundle identifier: /Library/Receipts/NeoOffice-2.2.3-Patch-1-Intel.pkg
2009-12-07 21:23:38.576 installer[2613:4207] PackageKit: *** Missing bundle identifier: /Library/Receipts/NeoOffice-2.2.3-Patch-3-Intel.pkg
2009-12-07 21:23:38.577 installer[2613:4207] PackageKit: *** Missing bundle identifier: /Library/Receipts/NeoOffice-2.2.3-Patch-5-Intel.pkg
2009-12-07 21:23:38.579 installer[2613:4207] PackageKit: *** Missing bundle identifier: /Library/Receipts/NeoOffice-2.2.4-Intel.pkg
2009-12-07 21:23:38.580 installer[2613:4207] PackageKit: *** Missing bundle identifier: /Library/Receipts/NeoOffice-2.2.4-Patch-2-Intel.pkg
2009-12-07 21:23:38.582 installer[2613:4207] PackageKit: *** Missing bundle identifier: /Library/Receipts/NeoOffice-2.2.4-Patch-3-Intel.pkg
2009-12-07 21:23:38.584 installer[2613:4207] PackageKit: *** Missing bundle identifier: /Library/Receipts/NeoOffice-2.2.4-Patch-5-Intel.pkg
2009-12-07 21:23:38.585 installer[2613:4207] PackageKit: *** Missing bundle identifier: /Library/Receipts/NeoOffice-2.2.5-Intel.pkg
2009-12-07 21:23:38.587 installer[2613:4207] PackageKit: *** Missing bundle identifier: /Library/Receipts/NeoOffice-2.2.5-Patch-1-Intel.pkg
2009-12-07 21:23:38.588 installer[2613:4207] PackageKit: *** Missing bundle identifier: /Library/Receipts/NeoOffice-2.2.5-Patch-2-Intel.pkg
2009-12-07 21:23:38.590 installer[2613:4207] PackageKit: *** Missing bundle identifier: /Library/Receipts/NeoOffice-2.2.5-Patch-7-Intel.pkg
installer: Package name is NeoRouter Client
installer: Upgrading at base path /
installer[2613]: -[IFDInstallController(Private) _buildInstallPlan]: location = file://localhost
installer[2613]: -[IFDInstallController(Private) _buildInstallPlan]: file://localhost/Users/gandrews/Downloa ... aemons.pkg
installer[2613]: -[IFDInstallController(Private) _buildInstallPlan]: file://localhost/Users/gandrews/Downloa ... client.pkg
installer[2613]: PackageKit: invalid package /Users/gandrews/Downloads/nrclient-0.9-9.1528-i386.mpkg/Contents/Packages/neorouterclientlaunchdaemons.pkg has no bundle identifier
2009-12-07 21:23:39.938 installer[2613:5e03] Package /Users/gandrews/Downloads/nrclient-0.9-9.1528-i386.mpkg/Contents/Packages/neorouterclientlaunchdaemons.pkg uses a deprecated pre-10.2 format (or uses a newer format but is invalid).
installer[2613]: Package file://localhost/Users/gandrews/Downloa ... aemons.pkg not supported by PK
installer[2613]: Will use IF session
installer[2613]: -[IFPkg(Info_Conversion_Private) _parseOldStyleForLanguage:] - can't find .info file (neorouterclientlaunchdaemons)
installer[2613]: The package "neorouterclientlaunchdaemons" could not be opened. This can happen if the package has incorrect permissions or if the package has been renamed.
installer[2613]: PFPackage::packageWithURL - can't instantiate package: /Users/gandrews/Downloads/nrclient-0.9-9.1528-i386.mpkg/Contents/Packages/neorouterclientlaunchdaemons.pkg
installer[2613]: Error opening package "neorouterclientlaunchdaemons.pkg".
installer[2613]: Install failed: The Installer could not install the software because there was no software found to install.
installer: The upgrade failed (The Installer could not install the software because there was no software found to install.)
Georges-iMac:Downloads gandrews$

(Looks a bit different from yours. . .)

--George


Top
 Profile  
 
 Post subject: Re: Bad packages for OS X?
PostPosted: Tue Dec 08, 2009 11:50 am 
Offline

Joined: Mon Dec 22, 2008 10:19 pm
Posts: 436
It seems installer on your imac cannot recognize the format of neorouterclientlaunchdaemons.pkg and handles it as pre-10.2 format. This is incorrect because our i386 release packages are built on Leopard. Any idea why this could happen?

_________________
Luke - NeoRouter Team


Top
 Profile  
 
 Post subject: Re: Bad packages for OS X?
PostPosted: Wed Dec 09, 2009 12:46 pm 
Offline

Joined: Wed Nov 18, 2009 3:43 pm
Posts: 14
Nothing general.

The packages install fine on my wife's system, which is running the same version of Snow Leopard as me. It seems--and I know very little about Mac internals--that the install DB is squirrelly on my machine.

Can I install the files manually?

I can try safe boot and then run the installations, but not until this evening.

(Late already. . .)

--G.


Top
 Profile  
 
 Post subject: Re: Bad packages for OS X?
PostPosted: Wed Dec 09, 2009 6:41 pm 
Offline

Joined: Mon Dec 22, 2008 10:19 pm
Posts: 436
Please first remove the previous installation completely.

To manually install nrclient:
Code:
1. tar -zxvf nrclient-0.9.9.1528-osx-x86.tar.gz
2. cd nrclient-0.9-9.1528-i386.mpkg/Contents/Packages/neorouterclient.pkg/Contents
3. gzip -cd Archive.pax.gz | cpio -i
    this will yield three files (nrclientcmd, nrservice, rmnrclient.sh), copy them to /Library/NeoRouter/
4. cd nrclient-0.9-9.1528-i386.mpkg/Contents/Packages/neorouterclientlaunchdaemons.pkg/Contents
    gzip -cd Archive.pax.gz | cpio -i
    this will yield one file (nrservice.plist), copy it to /Library/LaunchDaemons/
5. cd nrclient-0.9-9.1528-i386.mpkg/Contents/Packages/neorouterclient.pkg/Contents/Resources
    sudo ./postflight


To manually install nrserver:
Code:
1. tar -zxvf nrserver-0.9.9.1528-osx-x86.tar.gz
2. cd nrserver-0.9-9.1528-i386.mpkg/Contents/Packages/neorouterserver.pkg/Contents
3. gzip -cd Archive.pax.gz | cpio -i
    this will yield three files (nrserver, openssl.cnf, rmnrserver.sh), copy them to /Library/NeoRouter/
4. cd nrserver-0.9-9.1528-i386.mpkg/Contents/Packages/neorouterserverlaunchdaemons.pkg/Contents
    gzip -cd Archive.pax.gz | cpio -i
    this will yield one file (nrserver.plist), copy it to /Library/LaunchDaemons/
5. cd nrserver-0.9-9.1528-i386.mpkg/Contents/Packages/neorouterserver.pkg/Contents/Resources
    sudo ./postflight


Note: this only works for 0.9.9. use regular installer when possible.

_________________
Luke - NeoRouter Team


Top
 Profile  
 
 Post subject: Re: Bad packages for OS X?
PostPosted: Thu Dec 10, 2009 12:33 pm 
Offline

Joined: Wed Nov 18, 2009 3:43 pm
Posts: 14
The manual installation seems to have done the job. I'm headed off to work and I'll confirm the installation from a remote location, but everything on the nrserver box now seems right.

I think my issue may have been in not deleting the files in the /Library/LaunchDaemons folder before installing. Also, I was careful to remove the old version and then restart, to eliminate any lingering processes in memory.

After installing the packages manually, I restarted again.

--George


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 15 posts ]  Go to page Previous  1, 2

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron