Community


All times are UTC - 5 hours




Post new topic Reply to topic  [ 2 posts ] 
Author Message
 Post subject: Problem with CentOS 5.2
PostPosted: Thu Sep 23, 2010 11:58 am 
Offline

Joined: Wed Sep 22, 2010 12:44 pm
Posts: 4
I am having some problems with CentOS 5.2.
First I tried to install Neorouter Free and everything worked.
Then i removed it and installed the pro version.

Then I get problems: (both with server and client)

writing new private key to 'server.key'
-----
/
/lib /
ln: creating symbolic link `libcrypto.so.0.9.8' to `libcrypto.so.0.9.8e': File exists
ln: creating symbolic link `libssl.so.0.9.8' to `libssl.so.0.9.8e': File exists
/
Starting nrserver services:
[root@server1 ~]# /usr/bin/nrserver: symbol lookup error: /usr/bin/nrserver: undefined symbol: BIO_test_flags


Tried to uninstall the pro and then install free again and evereything worked. Any ideas what could be wrong?


Best regards,


Rene


Top
 Profile  
 
 Post subject: Re: Problem with CentOS 5.2
PostPosted: Thu Sep 23, 2010 2:02 pm 
Offline

Joined: Sun Nov 16, 2008 6:41 am
Posts: 1869
Hi renx123,

Please upgrade the openssl lib to 0.9.8e and it should work then.

NeoRouter Pro 1.0.0 was built on CentOS 5.3, which includes openssl 0.9.8e, while the CentOS 5.2 comes with openssl 0.9.8b, which does not support BIO_test_flags. Though symbol link creates the link but it is not compatible.

Since NR Free v1.1.1, we don't use openssl dynamic libs anymore and it works on almost any linux distros. In the next NR Pro release, it will go this way as well.

Thanks,
KevinZ - NeoRouter team


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron