Problem with CentOS 5.2
Page 1 of 1

Author:  renx123 [ Thu Sep 23, 2010 11:58 am ]
Post subject:  Problem with CentOS 5.2

I am having some problems with CentOS 5.2.
First I tried to install Neorouter Free and everything worked.
Then i removed it and installed the pro version.

Then I get problems: (both with server and client)

writing new private key to 'server.key'
/lib /
ln: creating symbolic link `' to `': File exists
ln: creating symbolic link `' to `': File exists
Starting nrserver services:
[root@server1 ~]# /usr/bin/nrserver: symbol lookup error: /usr/bin/nrserver: undefined symbol: BIO_test_flags

Tried to uninstall the pro and then install free again and evereything worked. Any ideas what could be wrong?

Best regards,


Author:  kevinz [ Thu Sep 23, 2010 2:02 pm ]
Post subject:  Re: Problem with CentOS 5.2

Hi renx123,

Please upgrade the openssl lib to 0.9.8e and it should work then.

NeoRouter Pro 1.0.0 was built on CentOS 5.3, which includes openssl 0.9.8e, while the CentOS 5.2 comes with openssl 0.9.8b, which does not support BIO_test_flags. Though symbol link creates the link but it is not compatible.

Since NR Free v1.1.1, we don't use openssl dynamic libs anymore and it works on almost any linux distros. In the next NR Pro release, it will go this way as well.

KevinZ - NeoRouter team

Page 1 of 1 All times are UTC - 5 hours
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group