Community


All times are UTC - 5 hours




Post new topic Reply to topic  [ 2 posts ] 
Author Message
 Post subject: client on 1&1 v-server is dead - but i see him
PostPosted: Wed Jan 26, 2011 4:44 pm 
Offline

Joined: Sat Jan 22, 2011 3:18 pm
Posts: 1
Hello,
first of all:
great stuff really fine working from home PC s

Until last week Neurouter works perfekt on Windows home PCs.
Because for that we hired virtual server with Ubuntu 10.04 from german provider 1&1.

Server is running
Client is running

From my windows PC i can see the client:
IP: 10.0.0.1
Status: online
Domain name right
Tux is coloured

but that is it
- no ping
- no ssh connection
- no HTML
- no smb

probably it is because 1&1 name there network adapters "venet" instead of "eth"

as suggested in manual i add
NicInterfaceName="venet"
in Feature.ini
without any result.
any Ideas ?

( it would be very sad to change to Hamachi becaus Neurouter works perfekt )

here my ifconfig output:

root@XXXXXXX:~# ifconfig
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:557 errors:0 dropped:0 overruns:0 frame:0
TX packets:557 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:78921 (78.9 KB) TX bytes:78921 (78.9 KB)

venet0 Link encap:UNSPEC HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
inet addr:127.0.0.1 P-t-P:127.0.0.1 Bcast:0.0.0.0 Mask:255.255.255.255
UP BROADCAST POINTOPOINT RUNNING NOARP MTU:1500 Metric:1
RX packets:1064 errors:0 dropped:0 overruns:0 frame:0
TX packets:976 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:123369 (123.3 KB) TX bytes:166966 (166.9 KB)

venet0:0 Link encap:UNSPEC HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
inet addr:87.XXX.XXX.XX P-t-P:87.XXX.XXX.XX Bcast:0.0.0.0 Mask:255.255.255.255
UP BROADCAST POINTOPOINT RUNNING NOARP MTU:1500 Metric:1

from Linux client and from windows client i see all user and all computer with right names


Top
 Profile  
 
 Post subject: Re: client on 1&1 v-server is dead - but i see him
PostPosted: Wed Jan 26, 2011 5:36 pm 
Offline

Joined: Sun Nov 16, 2008 6:41 am
Posts: 1869
Hi ricky-koeln,

There would be two issues with your VPS.

1.Permission to access /dev/net/tun, which is mandatory for NR client service.
Please check out here: viewtopic.php?f=8&t=4540

I think this is the root reason you cannot ping so far. If you can help collect log, we can confirm the issue.

2.In this kind of virtualized machine, I would recommend to use the parameter "HardwareId" instead of "NicInterfaceName", as the venet0 always has the same HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00 . If you have another VM, which will have the same HWaddr, this will cause NR clients keep trying log on one over another.

NR client uses a unique identifier for each computer/device. Without a valid ID, NR client service won't be able to connect to NR server and you won't see it in your computer list.

On Linux, it uses MAC as the default ID. You can also specify any adapter name by setting "NicInterfaceName", but the MAC must be unique. Or you can specify the ID manually by setting the "HardwareId" parameter.

For configuration, please refer to:
http://www.neorouter.com/wiki/index.php ... ationFiles

Let us know if you still have problem.

Thanks,
KevinZ - NeoRouter team


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron