Community


All times are UTC - 5 hours




Post new topic Reply to topic  [ 29 posts ]  Go to page Previous  1, 2, 3  Next
Author Message
 Post subject: Re: Server worked yesterday, is stuck "offline" today.
PostPosted: Sun Jul 03, 2011 1:36 am 
Offline

Joined: Mon Dec 22, 2008 10:19 pm
Posts: 436
hi bluejay41,

We have a private build for Ubuntu x64 based on NR Free v1.5.0 that fixes the log issue. Please give it a try.

http://download.neorouter.com/Downloads ... 0a/Ubuntu/

Thanks,
Luke

_________________
Luke - NeoRouter Team


Top
 Profile  
 
 Post subject: Re: Server worked yesterday, is stuck "offline" today.
PostPosted: Sun Jul 03, 2011 7:08 am 
Offline

Joined: Thu Jun 30, 2011 9:35 am
Posts: 49
Hi Luke,

I removed build 2810 from the 64-bit Ubuntu machine, installed build 2526 (both server and client). Remote clients left on build 2810--seems to be working OK.

Now, two hours later, nrservice on the 64-bit Ubuntu machine has not yet crashed! Makes me wonder if reverting to 2526 fixed ALL the problems I was having with nrservice, not just the Log.ini problem. Perhaps the stack smashing resulting from the inadvertent bug introduction is due to something simple but with far-reaching effects, like overlaying two different structures in core on the same pointer, which is harmless if and only if the routine that actually allocates the RAM is using sizeof() the larger structure, not the smaller one, when it allocates. Otherwise the resulting random memory violations could seem at first to be totally unrelated to each other.

Will leave this configuration running all day today, waiting to see if nrservice ever crashes. Logging is disabled for now (by renaming Log.ini to Log.ini.disabled). Will try the new private build and re-enable logging if/when nrservice resumes its random crashing.

I am surprised and impressed that someone is working on this bug on the weekend! Hope the developer gets a day off next week.

So cross my fingers and HOPE IT'S OK! Goodbye, Hamachi!


Top
 Profile  
 
 Post subject: Re: Server worked yesterday, is stuck "offline" today.
PostPosted: Mon Jul 04, 2011 7:41 am 
Offline

Joined: Thu Jun 30, 2011 9:35 am
Posts: 49
Hi Luke,

I ran NeoRouter all day yesterday, using build 2526, and nrservice never crashed. But this morning I booted the server computer (64 bit Ubuntu). As soon as it was up, I checked "ps aux | grep nrserv" and found nrserver was up but nrservice was not. Apparently died when started or soon after. I restarted it with "sudo /etc/init.d/nrservice.sh start" and it is running now but clearly something is still wrong.

Therefore I will uninstall NeoRouter, reinstall using your 2810a packages, enable logging, reboot the machine, and let you know what happens.

Thanks,

David E. (bluejay41)


Top
 Profile  
 
 Post subject: Re: Server worked yesterday, is stuck "offline" today.
PostPosted: Mon Jul 04, 2011 9:19 am 
Offline

Joined: Thu Jun 30, 2011 9:35 am
Posts: 49
Hi Luke,

On the reboot with the 2810a packages, I saw something during boot that I had not seen before: an error message flashed very quickly at the top of the screen but disappeared before I could read it or even see it clearly.

After the boot, I ran ps and saw that nrserver was running but nrservice was not. I manually started nrservice with init.d/nrservice.sh and it came up OK.

Looked at your log files, and there were a lot of them. I was using 100 as number of lines, and there were over 800 lines each for nrserver and nrservice. Do you want me to send them to you? Can you give me an email address?

I also checked syslog to see if I could spot the fugitive error message I saw during boot and found a few interesting lines at the very end of syslog:

Jul 4 09:07:42 parkwayL pulseaudio[1865]: pid.c: Daemon already running.
Jul 4 09:08:40 parkwayL AptDaemon: INFO: Initializing daemon
Jul 4 09:09:33 parkwayL NetworkManager: SCPlugin-Ifupdown: devices added (path: /sys/devices/virtual/net/nrtap, iface: nrtap)
Jul 4 09:09:33 parkwayL NetworkManager: SCPlugin-Ifupdown: device added (path: /sys/devices/virtual/net/nrtap, iface: nrtap): no ifupdown configuration found.
Jul 4 09:09:33 parkwayL NetworkManager: <WARN> device_creator(): /sys/devices/virtual/net/nrtap: couldn't determine device driver; ignoring...
Jul 4 09:09:33 parkwayL avahi-daemon[1151]: Joining mDNS multicast group on interface nrtap.IPv4 with address 10.0.0.2.
Jul 4 09:09:33 parkwayL avahi-daemon[1151]: New relevant interface nrtap.IPv4 for mDNS.
Jul 4 09:09:33 parkwayL avahi-daemon[1151]: Registering new address record for 10.0.0.2 on nrtap.IPv4.
Jul 4 09:09:35 parkwayL avahi-daemon[1151]: Registering new address record for fe80::84ce:6dff:fe37:4122 on nrtap.*.
Jul 4 09:09:44 parkwayL kernel: [ 178.650013] nrtap: no IPv6 routers present
Jul 4 09:13:41 parkwayL AptDaemon: INFO: Quiting due to inactivity
Jul 4 09:13:41 parkwayL AptDaemon: INFO: Shutdown was requested
Jul 4 09:17:01 parkwayL CRON[2008]: (root) CMD ( cd / && run-parts --report /etc/cron.hourly)

Do these syslog messages mean anything? Why was it unable to find a device driver for nrtap.IPv4, yet nrservice was able to run on my manual start via init.d?

What next?

Thanks,
Bluejay41


Top
 Profile  
 
 Post subject: Re: Server worked yesterday, is stuck "offline" today.
PostPosted: Mon Jul 04, 2011 2:14 pm 
Offline

Joined: Mon Dec 22, 2008 10:19 pm
Posts: 436
hi bluejay41,

You can send the log files to support@neorouter.com and we will take a look. Logs for nrservice will be most useful. I recommend setting a much larger number, like 30000, as the limit per file.

Thanks,
Luke

_________________
Luke - NeoRouter Team


Top
 Profile  
 
 Post subject: Re: Server worked yesterday, is stuck "offline" today.
PostPosted: Mon Jul 04, 2011 6:26 pm 
Offline

Joined: Thu Jun 30, 2011 9:35 am
Posts: 49
Hi Luke,

Sent you two nrservice log files, one of an nrservice which crashed upon starting or very soon thereafter, the other the first 100 lines of the log for an nrservice which was still running 10 hours after startup.

Bluejay41


Top
 Profile  
 
 Post subject: Re: Server worked yesterday, is stuck "offline" today.
PostPosted: Tue Jul 05, 2011 6:44 am 
Offline

Joined: Thu Jun 30, 2011 9:35 am
Posts: 49
Hi Luke,

Same thing happened this morning: when I booted the Ubuntu 64-bit server machine, nrserver came up and stayed up, but nrservice died immediately. So I started nrservice manually with "sudo /etc/init.d/nrservice.sh start" and nrservice came up and stayed up. Do you want either syslog or NeoRouter log output? Probably will be similar to what I sent you yesterday.

Out of the blue question: does it make any difference which starts first--nrserver or nrservice--on a machine which has both installed? Which do you start first?

Final question: do you have a spare 64-bit PC clone you could load with Ubuntu 10.4 and see if you get the same results, using your 2810a packages? Or do you think I should switch to Ubuntu 11.4, assuming that exists? Or SuSE Linux? There could be a Ubuntu bug mixed into all this, you know.

Thanks,
Bluejay41


Top
 Profile  
 
 Post subject: Re: Server worked yesterday, is stuck "offline" today.
PostPosted: Tue Jul 05, 2011 7:21 am 
Offline

Joined: Mon Dec 22, 2008 10:19 pm
Posts: 436
hi bluejay41,

We have both Ubuntu 10 and 11 64bit in our lab, and we do not see the issue you are experiencing. It should not matter whether nrservice or nrserver starts first.
If you have log enabled, nrservice/nrserver should create a new log file when it starts then dies. If you can send it to me, I can probably figure out the cause.

Thanks,
Luke

_________________
Luke - NeoRouter Team


Top
 Profile  
 
 Post subject: Re: Server worked yesterday, is stuck "offline" today.
PostPosted: Tue Jul 05, 2011 1:45 pm 
Offline

Joined: Thu Jun 30, 2011 9:35 am
Posts: 49
Hi Luke,

Will send you both logs for nrservice (the very brief one of the nrservice instance which died during or immediately after computer boot, plus the 16,000 line log file of the nrservice instance which I manually started after the first one had died).

But note that I have ALREADY sent you the brief log written by nrservice when it dies immediately on booting, AS WELL AS the first 100 lines (of over 16,000 lines) of the second nrservice which runs all day after being manually started.

Are you sure you want 16,000 lines of log of an nrservice which is running for 10-12 hours with no problems and never crashed? You can have them. Unless you write back in the next four hours, I will send them to you this evening when I get back to my test server. But I don't understand why you prefer that to the log file produced by the nrservice which crashed, which is of course very brief precisely because it crashed while starting up.

I can tell you now, however, that if the random crashes do not recur over the next few days, but only the one crash on bootup occurs and my manual restart of nrservice then runs all day and all night, that I will not consider that a fatal flaw for my purposes. I will switch to using NeoRouter anyway, because I can live with that minor inconvenience. It is the random crashes on a sometimes unattended server which would be intolerable.

In any case, my production NeoRouter server box is very likely to be a 32-bit Ubuntu, SuSE Linux, or Windows box, which might not display the nrservice problems at all.

Thanks,

David E.


Top
 Profile  
 
 Post subject: Re: Server worked yesterday, is stuck "offline" today.
PostPosted: Tue Jul 05, 2011 5:19 pm 
Offline

Joined: Mon Dec 22, 2008 10:19 pm
Posts: 436
hi bluejay41,

Thank you for sending us the log files. Unfortunately we cannot figure out the issue. Neither can we reproduce the issue in our lab. If the larger log file does not have valuable data, you do not need to send.
I am glad NeoRouter is meeting your requirements. Adding a cron job may help work around the issue you experience. We will also keep an eye during our testing.

Thanks,
Luke

_________________
Luke - NeoRouter Team


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 29 posts ]  Go to page Previous  1, 2, 3  Next

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron