NeoRouter
http://www.neorouter.com/forum/

No connection at all
http://www.neorouter.com/forum/viewtopic.php?f=8&t=5459
Page 1 of 1

Author:  ebbek [ Thu Mar 13, 2014 11:49 am ]
Post subject:  No connection at all

Hi

I have had NeoRouter working. But since I got a new cable modem, I have had zero luck. Here is what I have done so far:
  • Upgraded to the Pro version. I have used the free version long enough and you guys deserve some compensation ;)
  • Uninstalled the free version and cleaned out all lingering setup on all machines.
  • Installed the Pro version of the server and given it my product key.
  • Logged on to the Dashboard and changed the server IP address to my actual address. The dashboard shows that I have the pro version some there is some kind of communication.
  • Checked that port 32976 is forwarded to my server for TCP connections.
  • Tried to log on to my network from another machine. No go (see attached log files).
My server is a fully updated Ubuntu 12.04.4 LTS running on 32-bit HW. My client machine is a Windows 7 Ultimate running on 64 bit HW.

Attachments:
NRConsole_20140313_172940.log [8.63 KiB]
Downloaded 367 times
NRClient_20140313_172839.log [2.52 KiB]
Downloaded 364 times

Author:  kevinz [ Thu Mar 13, 2014 6:08 pm ]
Post subject:  Re: No connection at all

Hi ebbek,

Based on your log file, it seems that your server is not online yet. Can you double check the port-forwarding settings in your router? The listen port of the server must be open to the Internet so that NR clients can connect to it.

You can test the server status from Dashboard website.

Thanks,
KevinZ - NeoRouter team

Author:  ebbek [ Fri Mar 14, 2014 2:11 am ]
Post subject:  Re: No connection at all

The test on the Dashboard reports that:

"The address "<my IP address>:32976" is closed and the NeoRouter Server cannot be used at this time"

I have checked the port forwarding and it is set up correctly. I will call my ISP support (who are actually quite capable) and see whether they can help. My ISP have locked down parts of the settings on my cable modem and maybe there is some kind of conflict? We'll see...

Thanks for your help

Ebbe

Author:  ebbek [ Fri Mar 14, 2014 1:43 pm ]
Post subject:  Re: No connection at all

ebbek wrote:
I will call my ISP support (who are actually quite capable) and see whether they can help.

I've just got off the phone with my ISP. They have not blocked anything (they only block port 25).

However, I discovered something which I think is strange. The command
Code:
sudo netstat -ntlp | grep nrser

gives this result
Code:
tcp        0      0 127.0.0.1:32975         0.0.0.0:*               LISTEN      19060/nrservice

If I run the command
Code:
sudo nrserver -showsettings

I get this result:
Code:
NeoRouter server settings:
Domain Name: jeeb-vpn
Server Port: 32976
DHCP Subnet: 10.0.0.0
DHCP Netmask: 255.0.0.0
Account Lockout Threshold: -1

Why does netstat report a port number that is different from what nrserver reports?

Author:  mesa57 [ Tue Mar 18, 2014 2:07 pm ]
Post subject:  Re: No connection at all

nrservice listens on port 32975
nrserver should listen on port 32976 but apparently is not running with you.
Code:
tcp        0      0 127.0.0.1:32975         0.0.0.0:*               LISTEN      2417/nrservice
tcp        0      0 0.0.0.0:32976           0.0.0.0:*               LISTEN      2348/nrserver

Author:  ebbek [ Tue Mar 18, 2014 4:56 pm ]
Post subject:  Re: No connection at all

mesa57 wrote:
nrserver should listen on port 32976 but apparently is not running with you.

Thanks. Starting nrserver helped quite a lot :D

Page 1 of 1 All times are UTC - 5 hours
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/