Community


All times are UTC - 5 hours




Post new topic Reply to topic  [ 5 posts ] 
Author Message
 Post subject: CentOS 6.5 and abrupt disconnection of NeoRouter services
PostPosted: Sat Jun 06, 2015 12:44 am 
Offline

Joined: Thu Aug 07, 2014 7:04 pm
Posts: 8
Yesterday I installed CentOS 6.5 x64 on a virtual server and began using NeoRouter Pro Client - and it worked great, out of the box.

This morning, everything stopped.

1. I can ssh to the CentOS box (10.0.0.27) from another computer on the NR network (e.g. 10.0.0.2).
2. I can ping myself (10.0.0.27) from the CentOS box.
3. But I cannot ping any other machine anymore. In particular I wanted to contact 10.0.0.4 on a specific port.

netstat -nr
shows:

Code:
Kernel IP routing table
Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
176.75.85.0     0.0.0.0         255.255.255.0   U         0 0          0 eth0
165.253.0.0     0.0.0.0         255.255.0.0     U         0 0          0 eth0
10.0.0.0        0.0.0.0         255.0.0.0       U         0 0          0 nrtap
0.0.0.0         167.88.47.1     0.0.0.0         UG        0 0          0 eth0


when I telnet to the port:

Code:
Trying 10.0.0.4...
telnet: connect to address 10.0.0.4: Connection timed out


I know this can work since it did yesterday... is there any first aid I can do to help debug this? Does the routing table look ok? I turned off all the iptables service and there was no improvement.

Thanks!


Last edited by naia on Mon Jun 08, 2015 3:18 pm, edited 1 time in total.

Top
 Profile  
 
 Post subject: Re: CentOS 6.5 and abrupt disconnection of NeoRouter services
PostPosted: Sun Jun 07, 2015 9:59 am 
Offline

Joined: Sun Nov 16, 2008 6:41 am
Posts: 1868
Hi naia,

Since you can ssh to 10.0.0.27, the CentOS box works well. The problem is on the 10.0.0.4. Please take a look at it.

The routing looks good. If you can see 10.0.0.4 on the computer list, try ping or telnet or ssh and so on; if not working, please check firewall; nrservice process; nrtap adapter (ifconfig should give you the virtual IP) on the box.

If no clue, please enable logging and send the log file of the NR client service on the box to us, so that we can help you to investigate it.

Thanks,
KevinZ - NeoRouter team


Top
 Profile  
 
 Post subject: Re: CentOS 6.5 and abrupt disconnection of NeoRouter services
PostPosted: Sun Jun 07, 2015 1:46 pm 
Offline

Joined: Thu Aug 07, 2014 7:04 pm
Posts: 8
Thanks Kevin.

Quote:
Since you can ssh to 10.0.0.27, the CentOS box works well. The problem is on the 10.0.0.4. Please take a look at it.


It seems fine and I can RDP to it from any other machine in the NR network.

Quote:
The routing looks good. If you can see 10.0.0.4 on the computer list, try ping or telnet or ssh and so on; if not working, please check firewall; nrservice process; nrtap adapter (ifconfig should give you the virtual IP) on the box.


1. I tried nrclientcmd, and it looks perfect:

Quote:
NeoRouter Network Explorer - user@centos.domain.ip.com

> My Computers
10.0.0.4 toserve
10.0.0.26 work
10.0.0.3 home

Available Commands: changeview, wakeonlan, setproxy, changepassword, quit
Enter command:


In fact, (I just found this out), when I open two ssh sessions, and have one in nrclientcmd (so I'm at the "Enter command:" prompt in nrclientcmd), I can ping and use 10.0.0.4 in the other Centos box session - everything works like before!! As soon as I hit quit or Ctrl-C, I can no longer ping 10.0.0.4 from the Centos box. In both cases I can see the Centos box on a different NR Client computer list and ssh to the Centos box.

2. firewall - works with or without firewall (as stated above, if I'm in nrclientcmd at the Enter command prompt on a session, it works in another session)

3. nrservice process - appears to be working fine.

4. nrtap adapter - yes, the tun appears to be fine and I can see nrtap in ifconfig .


Quote:
If no clue, please enable logging and send the log file of the NR client service on the box to us, so that we can help you to investigate it.


Sure, is there some filter I can enable? I think it's strange I need to be logged into nrclientcmd to make it work, that wasn't like that before!


Top
 Profile  
 
 Post subject: Re: CentOS 6.5 and abrupt disconnection of NeoRouter services
PostPosted: Mon Jun 08, 2015 8:30 am 
Offline

Joined: Sun Nov 16, 2008 6:41 am
Posts: 1868
Hi naia,

It sounds like a normal behavior, if you set the block all or firewall on to the default user in NR Pro.

When a NR user signs in, the ACL rules associated apply to him so that he can remotely access the target computer; when he signs out, it falls back to the default user and the related rules will be applied.

Check your Computer-> ACL rules for the default user on the target computer, see if you give it permission to telnet.

Thanks,
KevinZ - NeoRouter team


Top
 Profile  
 
 Post subject: Re: CentOS 6.5 and abrupt disconnection of NeoRouter services
PostPosted: Mon Jun 08, 2015 3:22 pm 
Offline

Joined: Thu Aug 07, 2014 7:04 pm
Posts: 8
Great, thanks, perhaps it's because we nominally use the windows clients all the time, I hadn't realized that we would need to have a shell window open all the time with nrclientcmd running to keep logged in.

I hadn't thought that the "quit" in nrclientcmd meant to log out.

So for any non-default user we will have nrclientcmd actively logged in at the Neorouter prompt. I tried to background the task on the shell but it ended nrclientcmd.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 5 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 3 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to: