Community


All times are UTC - 5 hours




Post new topic Reply to topic  [ 2 posts ] 
Author Message
 Post subject: NR not connecting within network after restart
PostPosted: Mon Sep 28, 2015 9:42 pm 
Offline

Joined: Mon Sep 28, 2015 8:35 pm
Posts: 5
I have a self-hosted Ubuntu NR install of NeoRouter Free running in a VMWare Fusion VM. I have a variety of Macs on my network (Mountain Lion, Mavericks and Yosemite) that can access the server with no problem and they work great! The two machines that I use most of the time (my desktop and my laptop) will work once after a reinstall, but after a restart will never connect again (until another reinstall).

The other machines on the network work mostly, even after restarts, but at least one other has started to exhibit the same behavior after a restart. Interestingly, all three machines that have had issues are on Yosemite. I HAVE installed the newest TUNTAP installer BEFORE installing NR, but still end up at the same place.

I did have hairpin issues with my router when I installed a new router (MiktoTik CloudRouter) but those seem to have been resolved as it works for some of the machines all the time, and part of the time on the rest of the machines. When I take my laptop off-site, it connects to my server quite nicely--just not within the network. So it SMELLS like a hairpin issue, but other machines on the network log in and see each other just fine, so that's not a for-sure.

I have tried the settings for within the network and without, but have not found anything that works. I keep getting the message "Socket is not connected." The other machines with the exact same settings, version and OS access each other quite nicely.

What can I do to troubleshoot this? Could it still be the router that is blocking certain resources that NR needs? Is there something besides the usual port (32976, both UDP and TCP) that I should open? Is there a "discovery" port that needs to be available, ala Bonjour?

The router is pretty locked down and I had to exact some rather granular concessions from it for it to give up the NR ports initially, so it sticks in my mind that there might be something else that I need to add to the rules. The switch part of the router is a "smart switch" but is set to pass everything to and from the local network.

Other than that I really like NeoRouter and was considering buying a license and deploying it out to my various clients to access their servers, but I need to get this resolved first.


Top
 Profile  
 
 Post subject: Re: NR not connecting within network after restart
PostPosted: Mon Sep 28, 2015 10:01 pm 
Offline

Joined: Mon Sep 28, 2015 8:35 pm
Posts: 5
Never mind. Found another router rule to tweak and it connected sometime during the time it took me to blink. Phew!


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 2 posts ] 

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to: