Now NeoRouter works on Win 10, won't work on Ubuntu 16.04 ??
Page 1 of 1

Author:  bluejay41 [ Sun Apr 02, 2017 11:55 am ]
Post subject:  Now NeoRouter works on Win 10, won't work on Ubuntu 16.04 ??

Have I forgotten some needed step in installing NeoRouter on Linux (mostly Ubuntu 16.04 in my case)? My NeoRouter domain (free version), has clients running Win 10, Win 7 and Ubuntu 16.04. The domain mediation server is on the Win 7 machine for no particular reason except it is a 24/7 machine anyway. We use NeoRouter strictly for file serving at the moment. The important file-serving clients are that same Win 7 and one of the Win 10 machines, but for test purposes I have shared folders on nearly all the clients. All the machines are in work group WORKGROUP. All machines are behind NAT routers, in various locations within a few miles of each other. This has worked absolutely great since 2014 up until mid-2016, when we "upgraded" most of the Win 7 machines to Win 10.

Then several months of increasing troubles with Win 10, dropping network connections, unable to log in to the file-serving clients, etc. These problems always immediately followed any activity of Windows Update (even just a download with no immediate installation), and usually took a joggle of the Network Access icon or a couple of reboots to resolve. But that seems to have straightened out in the last week, and the Win 10 machines are now reliable, both as file servers and as clients accessing each others' shared folders.

But now the Ubuntu 16.04 clients on the same NeoRouter domain (and same work group WORKGROUP) can NOT access shared folders on either the Win 7, the Win 10, or even the other Ubuntu machines. Nor can the Win 10 machines connect to the Ubuntu 16.04 file-serving clients. The Ubuntu machines now cannot even access shared folders on other Ubuntu machines in the same building! I would suspect a Ubuntu problem except they worked great for 2+ years in this environment.

Ping works between all pairs of machines (except one which must have a firewall problem), both NR ping and OS's native ping. But trying to get past the credentials window is impossible if either or both the clients involved are Ubuntu 16.04 machines. When a Ubuntu machine tries to access the Win 7 machine (which is one of our important file servers, as well as being the NeoRouter server), you never even see a credentials window -- the remote connection window just disappears a second or two after you press Connect in the Connection window. When the Ubuntu machines try to access the Win 10 machines or the other Ubuntu machines, the credentials window just flashes and redisplays, as if the password had been wrong. Also, the Win 10 machines cannot access the Win 7 machine through NeoRouter, although they can through ordinary Windows Networking.

Have I forgotten how to install/configure Ubuntu machines? Download and install NeoRouter client, install Samba, install Java JRE so will work, then run either or plain old nrclientcmd to see the 10.0.0.x numbers, ping your target to make sure it's alive, then use the Ubuntu "Connect to server..." feature to access the target and its shared folders. This has worked for years! No more.

Note that Ubuntu does not even bother to run firewall software if you are behind a NAT router.

What am I doing wrong? Anti-virus scans are clean on the Win 10 computers, but those are not the problem anyway.

bluejay41 (aka David E.)

Author:  bluejay41 [ Sun Apr 02, 2017 4:38 pm ]
Post subject:  Re: Now NeoRouter works on Win 10, won't work on Ubuntu 16.04 ??

One difference between the way NR client acts on Ubuntu 16.04 vs on Win 10 is that the Ubuntu version shows the shares of the remote computer first, then asks for credentials. The NR client on Win 10 does just the reverse.

One difference between the way NR client acts now in 2017 on Ubuntu 16.04 vs in 2016 on Ubuntu 16.04 is that the current version's Connection window shows the phrase "Windows shares on smb (IP address)" rather than just "smb (IP address)".

Do these observations make any difference?

Comically, if I ask a Ubuntu 16.04 client to access its OWN shares through NeoRouter, it does so, and shows me the shares. When I click on one of them, it then shows me the credentials window, as I said in the first paragraph of this reply. But when I give my user name and password, it refuses to let me access (e.g. edit) my own shares on my own machine! When I try this trick on a Win 10 machine, it obediently lets me access the local shared folder and its files. This is in the same building, same router.

It is things like this that make me suspect a Linux version NeoRouter problem (alternately, just something I'm overlooking in the configuration of my Ubuntu machines) rather than a general Ubuntu problem. Certainly I have not seen an avalanche of similar problems with networking/VPNs on the Linux forums.

Author:  bluejay41 [ Mon Apr 03, 2017 4:00 pm ]
Post subject:  Re: Now NeoRouter works on Win 10, won't work on Ubuntu 16.04 ??

On a Ubuntu 16.4.1 computer at home, trying to access a Ubuntu 16.4.1 computer at work, both with free NeoRouter 4360 installed, I get entirely different windows during the process of trying to establish the connection than the windows I get when trying to establish a connection to a Windows 10 machine:
3. Credentials window.png
3. Credentials window.png [ 1.09 MiB | Viewed 9121 times ]
Note the two choices, Anonymous vs Registered User. I never saw anything like that before in the years I have used NeoRouter. And neither of the two choices does a damned thing, certainly does not connect me.

In this sequence, NeoRouter has ALREADY shown me the remote shares, unlike the sequence of events when trying to connect to a Win 10 machine about four feet away from the Ubuntu machine (both at work, using one of my Ubuntu machines at home to try to call in to them).

Note the heading on the window showing the shares in the background: it says "Windows shares on" This is just a cosmetic point, but that heading is wrong. The shares being shown are on a Ubuntu machine, not on Windows at all.

The red feathers belong to a Scarlet Macaw I got with my little Fuji camera, in Costa Rica.

Author:  bluejay41 [ Sun May 07, 2017 6:55 pm ]
Post subject:  Re: Now NeoRouter works on Win 10, won't work on Ubuntu 16.04 ??

Have had updates from both Microsoft and Ubuntu that have fixed some of the problems I've been having NeoRouter - obviously just their bugs, not NeoRouter's. Still having sporadic outages on a Win 7 client -- whenever it receives Windows Updates, it must be rebooted 2-3 times before Linux clients can again access its shared files. Formerly, Win 10 clients could not access either, but that seems to have been fixed.

One remaining problem seems to me to be a bug in SAMBA affecting at least most recent Samba version on Ubuntu 16.4.

From Samba's log on the machine holding the shared directory which no machines can access:
[2017/05/07 12:41:41.656689, 0] ../source3/param/loadparm.c:3259(process_usershare_file)
process_usershare_file: stat of /var/lib/samba/usershares/playshares failed. Permission denied

But the file mentioned exists with 775 permissions, and its directory exists with 775 permissions. Some bug in Samba, can't stat a file which Samba itself created! and which looks perfectly normal in gedit -- I noticed that a new version of Samba was distributed recently.

And of course the shared directory in question has been shared for a long time with no problems at all until now.

So I am closing this thread on NeoRouter. Have contacted Samba with a bug report.

Author:  trice001 [ Fri Sep 08, 2017 4:23 am ]
Post subject:  Re: Now NeoRouter works on Win 10, won't work on Ubuntu 16.04 ??


Author:  ruchikadmore [ Wed Feb 20, 2019 4:17 am ]
Post subject:  Re: Now NeoRouter works on Win 10, won't work on Ubuntu 16.04 ??

Excellent topic. Thank you.

Page 1 of 1 All times are UTC - 5 hours
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group