Community


All times are UTC - 5 hours




Post new topic Reply to topic  [ 12 posts ]  Go to page Previous  1, 2
Author Message
 Post subject: Re: Neorouter for LEDE?
PostPosted: Sun Nov 11, 2018 8:55 pm 
Offline

Joined: Tue Dec 17, 2013 3:19 pm
Posts: 20
I'm trying to get NeoRouterFree on OpenWRT 18.06.1 on a Linksys WRT3200ACM (/proc/cpuinfo lists it as 'ARMv7 Processor rev 1 (v7l)') and I too am running into the malformed package error:

Code:
root@OpenWrt:~# opkg install <neorouter_download_host>/Downloads/NRFree/Update_2.3.1.4360/inabox/Barrier_Breaker/nrserver-2.3.1.4360-free-barrier_breaker-ar71xx.ipk
Downloading <neorouter_download_host>/Downloads/NRFree/Update_2.3.1.4360/inabox/Barrier_Breaker/nrserver-2.3.1.4360-free-barrier_breaker-ar71xx.ipk
Collected errors:
* pkg_init_from_file: Malformed package file /tmp/opkg-dLGBMk/nrserver-2.3.1.4360-free-barrier_breaker-ar71xx.ipk.


Just for kicks I tried the other two processor versions (in case I got the processor type wrong) and they all give the same error.

I'm going to try to manually unpack the package and see if there are any library incompatibilities or if there is just something in the package info files that are not happy.

Basically, add a 'me too' to this thread.


Top
 Profile  
 
 Post subject: Re: Neorouter for LEDE?
PostPosted: Mon Nov 12, 2018 12:46 pm 
Offline

Joined: Tue Dec 17, 2013 3:19 pm
Posts: 20
Okay, I wrenched on this some and almost got somewhere.

The OpenWRT versions did not have one compiled for ARM (this Linksys is probably too new). So I downloaded the Raspberry Pi version and unpacked it on my Linux desktop. OpenWRT doesn't have /lib/ld-linux.so.3 but has /lib/ld-musl-armhf.so.1 instead. So I used patchelf to change the interpreter.

Code:
patchelf --set-interpreter /lib/ld-musl-armhf.so.1 nrserver
patchelf --set-interpreter /lib/ld-musl-armhf.so.1 nrsetup


Then I had to manually install some dependencies:

Code:
opkg install uclibcxx libpthread libuuid libopenssl libstdcpp


The executable will almost run, and I don't think I can fix the rest of these errors without downgrading libthread and cross compiling an old version of libssl (I really don't want to do either of those for obvious reasons).

Code:
root@OpenWrt:~/nrserver_armhf# nrserver -v
Error loading shared library libcrypt.so.1: No such file or directory (needed by /usr/bin/nrserver)
Error relocating /usr/bin/nrserver: __pthread_register_cancel: symbol not found
Error relocating /usr/bin/nrserver: __pthread_unregister_cancel: symbol not found


I could probably get LXC running on OpenWRT, but that would mean compiling a new kernel, and then install Raspberry Pi (taking even more storage) and maybe it would work.

I really like NeoRouterFree and wish it was Open Source so we could contribute back to it for things like this.


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 12 posts ]  Go to page Previous  1, 2

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to: