Neorouter for LEDE?
Page 2 of 2

Author:  rldleblanc [ Sun Nov 11, 2018 8:55 pm ]
Post subject:  Re: Neorouter for LEDE?

I'm trying to get NeoRouterFree on OpenWRT 18.06.1 on a Linksys WRT3200ACM (/proc/cpuinfo lists it as 'ARMv7 Processor rev 1 (v7l)') and I too am running into the malformed package error:

root@OpenWrt:~# opkg install <neorouter_download_host>/Downloads/NRFree/Update_2.3.1.4360/inabox/Barrier_Breaker/nrserver-
Downloading <neorouter_download_host>/Downloads/NRFree/Update_2.3.1.4360/inabox/Barrier_Breaker/nrserver-
Collected errors:
* pkg_init_from_file: Malformed package file /tmp/opkg-dLGBMk/nrserver-

Just for kicks I tried the other two processor versions (in case I got the processor type wrong) and they all give the same error.

I'm going to try to manually unpack the package and see if there are any library incompatibilities or if there is just something in the package info files that are not happy.

Basically, add a 'me too' to this thread.

Author:  rldleblanc [ Mon Nov 12, 2018 12:46 pm ]
Post subject:  Re: Neorouter for LEDE?

Okay, I wrenched on this some and almost got somewhere.

The OpenWRT versions did not have one compiled for ARM (this Linksys is probably too new). So I downloaded the Raspberry Pi version and unpacked it on my Linux desktop. OpenWRT doesn't have /lib/ but has /lib/ instead. So I used patchelf to change the interpreter.

patchelf --set-interpreter /lib/ nrserver
patchelf --set-interpreter /lib/ nrsetup

Then I had to manually install some dependencies:

opkg install uclibcxx libpthread libuuid libopenssl libstdcpp

The executable will almost run, and I don't think I can fix the rest of these errors without downgrading libthread and cross compiling an old version of libssl (I really don't want to do either of those for obvious reasons).

root@OpenWrt:~/nrserver_armhf# nrserver -v
Error loading shared library No such file or directory (needed by /usr/bin/nrserver)
Error relocating /usr/bin/nrserver: __pthread_register_cancel: symbol not found
Error relocating /usr/bin/nrserver: __pthread_unregister_cancel: symbol not found

I could probably get LXC running on OpenWRT, but that would mean compiling a new kernel, and then install Raspberry Pi (taking even more storage) and maybe it would work.

I really like NeoRouterFree and wish it was Open Source so we could contribute back to it for things like this.

Page 2 of 2 All times are UTC - 5 hours
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group