Impossible to add new client
Page 1 of 1

Author:  theshooter [ Tue Jul 23, 2019 6:52 am ]
Post subject:  Impossible to add new client

Hello everybody,
first of all, I want to say that I have been using neorouter for the past 4 years and I am very happy with it.
I have a network of 4-6 Raspberries at different locations and I use Neorouter to ssh to them.
I am using Neorouter Free, port 32976 is listening.

The problem I encounter is when I try to login with a new Raspberry.
I created a new user and am trying to login from the same LAN as the server. I use the domain name, as I always did before, when setting up each Raspberry.
The problem now is that nrclientcmd will login but only for a couple of seconds and then kick me out giving Transport endpoint not connected error.

And while it will stay connected, I can see that this new Raspberry will take the place of an already connected device, which is strange. But that old device will reconnect and kick the new one out.

Another strange thing occurs at the login step. You can see the attached screen capture. At the first line it will say castellon4@ELTV-Barcelona. "castellon4" is the new user I created for the new Raspberry but ELTV-Barcelona is the computer name of an already existing and connected Raspberry. Why it would behave like that?

In NRClient for Mac, in My computers section, the new Raspberry will never appear but it will take another's place for a short time (computer name will always remain the same).

Client (and Server) version is: NeoRouter Free [Version
NeoRouter server settings:
Domain Name:
Server Port: 32976
DHCP Subnet:
DHCP Netmask:
Account Lockout Threshold: -1

Has this happened to anybody else?

Author:  theshooter [ Wed Jul 24, 2019 5:10 am ]
Post subject:  Re: Impossible to add new client

Problem solved thanks to Kevin. He answered via the official support ticket system.

For those interested, my problem was that I cloned SD cards between Raspberries and on the clone remained some files that identified each machine. Even if you uninstall neorouter those files may remain there. The important one is Client.xml
The solution is to stop nrclientcmd:
sudo killall nrservice

and delete it:
rm /usr/local/ZebraNetworkSystems/NeoRouter/Client.xml

then reboot and log back in to nrclientcmd.

Thanks again Kevin.

Author:  frankalvin [ Wed Jan 15, 2020 11:16 pm ]
Post subject:  Re: Impossible to add new client

Thanks. Problem solved.

Page 1 of 1 All times are UTC - 5 hours
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group