NeoRouter
http://www.neorouter.com/forum/

0.9.7 doesn't work with Tomato on Buffalo WHR-HP-g54
http://www.neorouter.com/forum/viewtopic.php?f=8&t=796
Page 1 of 1

Author:  holterdipolter [ Sat Aug 01, 2009 2:15 pm ]
Post subject:  0.9.7 doesn't work with Tomato on Buffalo WHR-HP-g54

Hi,

I tried to update Neorouter Server to 0.9.7 on a Bufallo WHR-HP-g54 with tomato. The previous Version 0.9.6 worked properly.
However, I'm not able to run the new version. With top command I can see Neorouter is not running, although I used the same install-procedure and formatted the jffs-folder.
When I switch back to 0.9.6, neorouter runs properly again.

I noticed, that the size of the new firmware is a little bit bigger than the previous version. So, is it maybe a problem of insufficient memory? Are I'm not able to run the new version on this router?
Tomato shows 384kb total memory and 60kb memory free for jffs when I flash your latest firmware.

Thanks,

Simon

Author:  kevinz [ Sat Aug 01, 2009 5:39 pm ]
Post subject:  Re: 0.9.7 don't work with Tomato on Buffalo WHR-HP-g54

Hi Simon,

Thanks for your report. Can you check this?

1. Make sure you are using the tomato version, not tomato ND.
2. After flash with the new firmware, format the jffs-folder
Then you may want to restart the router, so that NeoRouter server can initialize the database and ssl certification files. These files will be stored in /jffs by default. Without them, nrserver cannot start.

3. If it does not work, please check the /jffs folder. 3 files are necessary: neorouter_0_0_1.db, server.crt and server.key.

Your jffs size seems a little bit smaller, but should be good enough for at least 30 computers.

Let us know if you still have problem.

Thanks,
KevinZ - NeoRouter team

Author:  holterdipolter [ Sun Aug 02, 2009 6:33 am ]
Post subject:  Re: 0.9.7 don't work with Tomato on Buffalo WHR-HP-g54

Hi KevinZ,

ok, problem is solved. When I checked the files, I saw the Neorouter-files in the /usr/bin/ were changed from "neorouter" to "nrserver". So I just changed the scriptline, and now it works.
Maybe you can change it in the manual.

Thanks for your fast support,

Simon

... by the way: the downloadlink for the ubuntu-client seems to be dead. Maybe you could fix it. Thanks!

Author:  kevinz [ Sun Aug 02, 2009 8:59 am ]
Post subject:  Re: 0.9.7 doesn't work with Tomato on Buffalo WHR-HP-g54

Thanks Simon, the link for the ubuntu client has been fixed.

--Kevin

Author:  lebudin [ Thu Jan 24, 2019 1:46 am ]
Post subject:  Re: 0.9.7 doesn't work with Tomato on Buffalo WHR-HP-g54

...

Author:  wukefeb [ Mon Feb 04, 2019 3:30 am ]
Post subject:  Re: 0.9.7 doesn't work with Tomato on Buffalo WHR-HP-g54

..

Page 1 of 1 All times are UTC - 5 hours
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group
http://www.phpbb.com/