Community


All times are UTC - 5 hours




Post new topic Reply to topic  [ 15 posts ]  Go to page 1, 2  Next
Author Message
 Post subject: Server service started but stopped immediatelly
PostPosted: Wed Nov 03, 2010 11:27 am 
Offline

Joined: Wed Nov 03, 2010 11:05 am
Posts: 8
WINDOWS XP PRO SP2 CZECH

"NRServer.exe" service is immediately stopped after its start. (Automatic or manual = no difference)

The same behavior for last software version and previous one.

I made "dump" file for diagnostics.
Attachment:
NRServer_20101103_165027.log [3.11 KiB]
Downloaded 635 times


Can you solve this issue?


Best regards


Top
 Profile  
 
 Post subject: Re: Server service started but stopped immediatelly
PostPosted: Wed Nov 03, 2010 1:12 pm 
Offline

Joined: Sun Nov 16, 2008 6:41 am
Posts: 1873
Hi val_ogar,

Based on your log file, I can see the NR server failed to open the database file.

On WinXP, the database file of NR Free is C:\Documents and Settings\All Users\Application Data\ZebraNetworkSystems\NeoRouter\NeoRouter_0_0_1.db . Please check if the file gets locked or corrupted.

If you cannot find out the problem, please remove the file and re-install the server.

Thanks,
KevinZ - NeoRouter team


Top
 Profile  
 
 Post subject: Re: Server service started but stopped immediatelly
PostPosted: Wed Nov 03, 2010 4:36 pm 
Offline

Joined: Wed Nov 03, 2010 11:05 am
Posts: 8
Thank's for fast response...

Problem is that database file is not existing in "C:\Documents and Settings\All Users\Application Data\ZebraNetworkSystems\NeoRouter\.."

Database file is not existing in any directory after installation.

If i tried to copy existing copy of NeoRouter_0_0_1.db (from different computer installation) to the right place, It doesn't help also.

Windows Application event log says for NRServer service , when it is trying to start: ID:3 ... no description ...

Next probably related issue:
During installation, before Domain form appearance, i have error: 1460. ( English description already existing somewhere in forum) I need to press OK in dialog box ... and installation continues with Domain form. But there is not possible create domain. It says "Domain cannot be created. Check ... bla bla". If i try once more with the same name ... it says "It is already registered". If i try to use existing domain name ... again "Domain not existing ..." ....... never ending loop .... There is only possibility to cancel wizard to end the installation.

There was exactly the same behavior with previous software version.

:roll:


Top
 Profile  
 
 Post subject: Re: Server service started but stopped immediatelly
PostPosted: Wed Nov 03, 2010 5:04 pm 
Offline

Joined: Sun Nov 16, 2008 6:41 am
Posts: 1873
Hi val_ogar,

Does your server have access to the Internet while installing? The installer will connect to our server (443/tcp) to create/check the domain information. If it cannot connect to our server, it gives the error message. Please make sure the server can access the Internet without setting proxy.

If you have previous database file, it should be recognized. We can help you verify it if you want and send it to support@neorouter.com

Thanks,
KevinZ - NeoRouter team


Top
 Profile  
 
 Post subject: Re: Server service started but stopped immediatelly
PostPosted: Thu Nov 04, 2010 4:00 am 
Offline

Joined: Wed Nov 03, 2010 11:05 am
Posts: 8
Hi,

There is internet access without proxy on NRserver installation computer. (Tested with IE v.7 - DASHBOARD web page displayed without any problems)

NRserver database file is not created on this problematic computer during installation. I don't have any one from installation on this computer. (I tried to use db file from another installation on different computer. it doesn't work also.)

Thanks


Top
 Profile  
 
 Post subject: Re: Server service started but stopped immediatelly
PostPosted: Thu Nov 04, 2010 9:26 am 
Offline

Joined: Sun Nov 16, 2008 6:41 am
Posts: 1873
Hi val_ogar,

I need to figure out why the database file cannot be opened on your machine. Can you try this?

Just install the server in your way, it may give error message or something, but you did install the files on your machine. Then go to the services.msc, stop the NR server service and try the following command manually.
1. cd to the installation folder
2. mkdir c:\temp and make sure you have write permission to this folder
3. run NRServer.exe /app -dbroot c:\temp , it should run and create a database under c:\temp folder.

Let us know the results. If it still does not work, see if it generates the db file.

Thanks,
KevinZ - NeoRouter team


Top
 Profile  
 
 Post subject: Re: Server service started but stopped immediatelly
PostPosted: Thu Nov 04, 2010 12:42 pm 
Offline

Joined: Wed Nov 03, 2010 11:05 am
Posts: 8
Hi,

"NeoRouter_0_0_1.db" was created in c:/temp.
But "dos console window" with command is never closed.

#########################################
Microsoft Windows XP [Verze 5.1.2600]
(C) Copyright 1985-2001 Microsoft Corp.

C:\Program Files\ZebraNetworkSystems\NeoRouter>NRServer.exe -agentmode -dbroot c:\temp
^C
C:\Program Files\ZebraNetworkSystems\NeoRouter>
#########################################

Only Ctrl+C closes "dos console window".

When I copy created database in "data" folder, there is the same result = No success to start service NRServer.


Maybe some idea:
Original English data path is
"C:\Documents and Settings\All Users\Application Data\ZebraNetworkSystems\NeoRouter\.."
Because it is CZECH version of XP, real data path is
"c:\Documents and Settings\All Users.WINDOWS\Data aplikací\ZebraNetworkSystems\NeoRouter\.."

Especially character "í" can make troubles ....

Thanks


Top
 Profile  
 
 Post subject: Re: Server service started but stopped immediatelly
PostPosted: Thu Nov 04, 2010 1:08 pm 
Offline

Joined: Sun Nov 16, 2008 6:41 am
Posts: 1873
Hi val_ogar,

Thanks for your response. Seems the problem is related to the file. It's correct that the dos window is opened, as nrserver is running until you kill it.

Can you run the Network Explore and choose the menu item "Help" >> "Troubleshooting" >> "Open Configuration Folder" see if it can open it? This will test it NR app can recognize the path, including the "i". And you can also try to remove the /ZebraNetworkSystems folder, I wonder if some app lock the folder.

Thanks,
KevinZ - NeoRouter team


Top
 Profile  
 
 Post subject: Re: Server service started but stopped immediatelly
PostPosted: Thu Nov 04, 2010 1:29 pm 
Offline

Joined: Wed Nov 03, 2010 11:05 am
Posts: 8
Hi again,

Configuration Folder path is recognized well.
I can remove "/ZebraNetworkSystems" folder or rename it. No problem.

Can be any conflict with other software?
OpenVPN, Bitvise WinSSHD are also running on this computer.

Thanks for your patience ... :-)


Top
 Profile  
 
 Post subject: Re: Server service started but stopped immediatelly
PostPosted: Thu Nov 04, 2010 8:03 pm 
Offline

Joined: Sun Nov 16, 2008 6:41 am
Posts: 1873
Hi val_ogar,

OpenVPN, Bitvise WinSSHD should be ok.

Are you running TortoiseSVN on the machine?

Thanks,
KevinZ - NeoRouter team


Top
 Profile  
 
Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 15 posts ]  Go to page 1, 2  Next

All times are UTC - 5 hours


Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron