install (network explorer) fails under vista 32 (
Page 1 of 1

Author:  zifnab [ Sun Jul 05, 2009 7:52 pm ]
Post subject:  install (network explorer) fails under vista 32 (

i installed the server on a xp sp3 computer without any trouble.
i then wanted to install the network explorer (client part only) on a vista 32 computer (not the portable version, as i want to permanently register the vista computer on the neorouter vpn). the install fails under vista (a few minutes after i get the popup to trust the driver install, even if not signed). it says: "an error occurred while install neorouter. the installer will roll back to original status and quit."
nothing get installed (no network adapter, no app).
here are the specs:
vista 32 sp1 (ultimate, up to date), english, other network adapters: ethernet, 802.11n usb trendnet, vmware player, hamachi, teamviewer (all up to date). uac is enabled. same result if i launch neorouter setup with admin privileges. by the way, current user is admin (still, uac is enabled). portable version works (useless on this computer, it will be priceless on some external computers to join the vpn).
i may have had a previous version installed at some point (0.9.5), but never used it, and i uninstalled it before trying to install 0.9.6.

i can give more details if needed, or run a debug setup.exe if you want to log and narrow down what's going on.

thanks for your help.

Author:  kevinz [ Mon Jul 06, 2009 2:13 pm ]
Post subject:  Re: install (network explorer) fails under vista 32 (

Hi zifnab,

Thanks for your report. It would be nice if you can help us to collect more information.

If you have a 7zip installed, you can simply unzip the setup file to a temp folder, then you can see a file called "NeoRouter-". Try to run it see if it works.

KevinZ - NeoRouter team

Author:  zifnab [ Mon Jul 06, 2009 5:57 pm ]
Post subject:  Re: install (network explorer) fails under vista 32 (

hi kevinz.

i actually tried that even before u mentionned it :)
to be thorough, i retried today and made 4 attempts:
- NeoRouter-
- NeoRouter- with admin rights
- NeoRouterSetup.exe
- NeoRouterSetup.exe with admin rights
all 4 ended the same way as the regular install (very same error message): roll back during the zebratap step (a few minutes after accepting the popup to install the unsigned driver).

anything else we can try.
i am ready to help.


Author:  kevinz [ Mon Jul 06, 2009 9:01 pm ]
Post subject:  Re: install (network explorer) fails under vista 32 (

Your information is very helpful. Can you help to check the driver on your computer?
You can copy the tapinstall.exe file from your xp machine C:\Program Files\ZebraNetworkSystems\NeoRouter\Driver folder, then type "tapinstall find zebratap" in a command prompt. Then type "tapinstall status zebratap" to check the status.


Author:  zifnab [ Wed Jul 08, 2009 6:00 pm ]
Post subject:  Re: install (network explorer) fails under vista 32 (

sorry for the late answer, I was'nt available yesterday.

I copied the file tapinstall.exe from my xp computer to the vista one.
I did copy the file in a folder where I do have full access (I mean I avoided special protected folders like "C:\Program Files" and its subfolders...).
I opened a prompt to this folder, and launched the 2 command lines you mention (remember nothing neorouter related is installed on the vista computer, the roll back during install removed everthing: app, folder, driver (I think it never managed to install the latter anyway)).

so, when I run the command, the UAC is triggered ("an unidentified program wants access to your computer", which I do allow). a new (black) command prompt window is opened but disappears instantly.
to capture any output, I then tried:
tapinstall find zebratap > find.txt
the find.txt is empty.

the very same thing happened with
tapinstall status zebratap
I also tried tapinstall status zebratap > status.txt
with the same result: status.txt is empty.


ps: just for the record, I tried the commands on the xp computer.
of course they worked like a charm (without opening a new command prompt window). I even tried to capture the output the same way I tried on vista: the find.txt and status.txt are properly filled under xp: 1 matching device, driver is running...).

ready to try other things...

Author:  kevinz [ Thu Jul 09, 2009 6:55 am ]
Post subject:  Re: install (network explorer) fails under vista 32 (

Hi zifnab,

Thanks for your help. Basically, I guess there would be some issue when installing the driver. We will do more test.

KevinZ - NeoRouter team

Author:  wiguhud [ Tue Feb 26, 2019 1:01 am ]
Post subject:  Re: install (network explorer) fails under vista 32 (


Page 1 of 1 All times are UTC - 5 hours
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group

Fatal error: Not able to open ./cache/data_global.php in C:\NeoRouterWebsite\htdocs2\nrweb\forum\includes\acm\acm_file.php on line 106