All times are UTC - 5 hours

Post new topic Reply to topic  [ 1 post ] 
Author Message
 Post subject: Linux NRService Segment Fault error
PostPosted: Wed May 22, 2013 12:57 pm 

Joined: Wed May 22, 2013 12:50 pm
Posts: 1

I'm getting NRService (v1.9) Segment faults after connecting to the VPN (from an NR android client v1.9). NRService is stable if no connections are in operation. After segfault the android client connection remains but the virtual IP address disappears.

NRService (and NRServer) are running on a Linux 32bit install using nrservice v1.9 build 3800 (tried various distributions).

Last few lines of Log output:

2013-05-22 17:44:16|24352|3058895728| | -[void CStdTcpDevice::_OnReceive(BYTE*, DWORD)](hr=0x0)
2013-05-22 17:44:16|24352|3016817520| | +[void CUdpBase<UDPDEVICE>::SocketDevice_OnReceive(BYTE*, DWORD) [with UDPDEVICE = CStdUdpDevice]]
2013-05-22 17:44:16|24352|3016817520| | +[HRESULT CMsgQueue::Append(BYTE*, DWORD)]
2013-05-22 17:44:16|24352|3016817520| | -[HRESULT CMsgQueue::Append(BYTE*, DWORD)](hr=0x0)
2013-05-22 17:44:16|24352|3016817520| | +[HRESULT CMsgQueue::GetNextPacket(CNetData*)]
2013-05-22 17:44:16|24352|3016817520| | +[DWORD CMsgQueue::GetPacket(BYTE**)]
2013-05-22 17:44:16|24352|3016817520| | +[DWORD CMsgQueue::EvaluatePacketList()]
2013-05-22 17:44:16|24352|3016817520| | -[DWORD CMsgQueue::EvaluatePacketList()](hr=0x0)
2013-05-22 17:44:16|24352|3016817520| | +[HRESULT CMsgQueue::GetBytes(BYTE**, DWORD)]
2013-05-22 17:44:16|24352|3016817520| | -[HRESULT CMsgQueue::GetBytes(BYTE**, DWORD)](hr=0x0)
2013-05-22 17:44:16|24352|3016817520| | -[DWORD CMsgQueue::GetPacket(BYTE**)](hr=0x607)
2013-05-22 17:44:16|24352|3016817520| | -[HRESULT CMsgQueue::GetNextPacket(CNetData*)](hr=0x0)
2013-05-22 17:44:16|24352|3016817520| | +[void CPeerSocket<PEERSOCKETBASE>::SocketBase_OnNewMsg(CNetData*) [with PEERSOCKETBASE = CUdpBase<CStdUdpDevice>]]
2013-05-22 17:44:16|24352|3016817520| | +[virtual void CTunnelP2P::PeerSocketCallback_OnNewMsg(CNetData*)]
2013-05-22 17:44:16|24352|3016817520| | +[HRESULT CTunnel::OnPeerData(CNetData*)]

Dmesg output:

[715196.321032] nrtap: no IPv6 routers present
[791723.606502] nrservice[23760]: segfault at bbf0841c ip 08063831 sp b3cd2310 error 4 in nrservice[8048000+267000]
[791723.606842] nrservice used greatest stack depth: 5220 bytes left
[792023.974020] nrtap: no IPv6 routers present
[792640.000001] nrservice[24080]: segfault at bbe8241c ip 08063831 sp b3c4c310 error 4 in nrservice[8048000+267000]
[792938.415033] nrtap: no IPv6 routers present
[792997.899206] nrservice[24175]: segfault at bbef541c ip 08063831 sp b3cbf310 error 4 in nrservice[8048000+267000]
[793242.916260] nrserver used greatest stack depth: 5184 bytes left
[793259.930034] nrtap: no IPv6 routers present
[793379.893225] nrservice[24386]: segfault at bbf4441c ip 08063831 sp b3d0e310 error 4 in nrservice[8048000+267000]

Please advise how to fix? Please note no IPv6 devices are configured or running on the network.

I've tried using HostIPType=1 to force IPv4 support only but nrservice still crashes. Also, manually starting the IPv6toIPv4 tunnel (sit0) which had a little more success (some traffic came through) but NRService segfaults still after a while.


Display posts from previous:  Sort by  
Post new topic Reply to topic  [ 1 post ] 

All times are UTC - 5 hours

Who is online

Users browsing this forum: No registered users and 3 guests

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to: